0

Since yesterday my Postfix stopped working: It doesn't receive any e-mails anymore (from other email addresses, not my own). There's nothing in mail.log or mail.err. Yesterday I installed fail2ban on my Ubuntu, did update & upgrade, and installed sendmail with fail2ban, which was an error, I removed sendmail again. But now I just can't get postfix to work. When I get its status it says

root@vps219158:/etc/init.d# sudo systemctl status postfix.service
* postfix.service
Loaded: masked (/dev/null; bad)
Active: inactive (dead)

And when I try to restart it

Failed to restart postfix.service: Unit postfix.service is masked.

I don't understand why it is masked.

Fail2ban is deactivated, I also checked the iptables: Nothing is banned. When I send an email to my email account from any one of my 3 other email accounts (@hotmail.com etc.) it doesn't report that the mails couldn't be sent - they just don't appear in my inbox (i.e. not on the server, "mail" command shows no new mails).

What more could I test? What could possibly lead to this issue?

EDIT: Status is: From outside, the SMTP connection fails. Postfix says it's running. Nothing in mail.log/err. It ran until yesterday. On localhost, I can telnet to "localhost 25" and send a mail, but it doesn't get to my inbox (same for ehlo mydomain.com and ehlo localhost).

Thanks in advance for some help!

  • now I unmasked the service manually, restarted it, now Postfix is at least active & running - but it still doesn't receive any mail anymore, and mail.log/mail.err show nothing. – Doidel Sep 12 at 6:38
  • On second thought, if Postfix logs nothing at all, but is still active, maybe the mail fails at some earlier stage. Hmm... So: From outside, the SMTP connection fails. – Doidel Sep 12 at 6:53
0

Ok, that was tough:

  • I reinstalled postfix (apt-get postfix)
  • I ran newaliases because some aliases were missing
  • I had to reboot because port 25 was still in use even though I had uninstalled sendmail
  • I had to unmask the postfix service

No clue why all of this lead to the solution, I couldn't identify the source of the problem. But apparently, now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.