Here's the problem. Projectile is installed and configured. I've initialized my emacs directory with .projectile file. When run projectile-switch-directory (actually it's helm-projectile-switch-directory with projectiled-dired as the follow up action.) helm returns a list of all of the files in the directory containing the .projectile file.

The same occurs when I add a .gitignore to a directory (in this case a hugo directory at the same level relative the root as the emacs directory).

In .projectile, nothing seems to work... neither +/dir, nor -dir, nor *dir, nor dir/.

In .gitignore it is the same, nothing works. projectile-switch-project returns 20 or so results when there are only two repos initilized on the entire computer (incidentally, one of the initialized (recognized by projectile) directories, was automatically detected, while others on the system with .git directories were not). The latter because, presumably, I visited that directory since installing projectile.

Is this an indexing issue? (I've tried with hybrid and native indexing, alien doesn't work on my windows 10 system).

Is there a way to control indexing? I.E., can I get projectile to index a directory at my command (projectile-index-directory isn't interactive).

To recap:

Here's my .projectile file:


I've also tried by marking the directories I want to keep with +/ , and *

The solution should be simple enough, but I don't know enough about projectile to know if it's an indexing issue or a syntax issue.

Any takers?


1 Answer 1


Current solution is to manually edit the projectile-bookmarks.eld file, in my case located c:/emacs/.emacs.d/projectile-bookmarks.eld.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .