1

I have a newish laptop that I've been using for a couple of months. For the most part I love this computer, but there is one headache I absolutely have to solve in order to maximize productivity on this device.

Here's the basics on my device:

Here's the problem. The Touchpad (technically called a "ClickPad," the latest generation of Synaptic touchpad technology) cannot be disabled. It's large, and though the software used to manage it tries to prevent unwanted taps, moves, selections, etc. while typing, it's less than adequate. I need to be able to disable and enable this touchpad on the fly using a keystroke.

I have the Windows Toolkit installed so I can use devcon, but although devcon can find the device and show me its status:

PS C:\WINDOWS\system32> devcon hwids *Syn*
ACPI\SYN3288\4&EC6F790&0
    Name: Synaptics SMBus ClickPad
    Hardware IDs:
        ACPI\VEN_SYN&DEV_3288
        ACPI\SYN3288
        *SYN3288
    Compatible IDs:
        *ETD0000
        *PNP0F13
1 matching device(s) found.
PS C:\WINDOWS\system32> devcon status "ACPI\SYN3288"
ACPI\SYN3288\4&EC6F790&0
    Name: Synaptics SMBus ClickPad
    Driver is running.
1 matching device(s) found.

When I go to disable this device, It's "No matching device(s) found:"

PS C:\WINDOWS\system32> devcon disable "ACPI\SYN3288"
ACPI\SYN3288\4&EC6F790&0                                    : Disable failed
No matching devices found.

I am running the latest, 64bit devcon for Windows 10, and I am able to disable/enable other devices, such as the touchscreen:

PS C:\WINDOWS\system32> devcon disable "ACPI\ELAN2514"
ACPI\ELAN2514\4&33AB941E&0                                  : Disabled on reboot
The 1 device(s) are ready to be disabled. To disable the devices, restart the
devices or reboot the system .

When I go into Device Manager, I find that I'm unable to disable the touchpad even there, as there is no option to do so in the right-click context menu and the "disable driver" button is grayed out in the properties driver tab:

Right click on ClickPad in Device Manager

enter image description here

There are no switches or built-in hotkeys (as would normally be present on other HP laptops). I have the most up-to-date driver from HP (literally just a few days old). I've discussed this with HP support and they tell me that the inability to disable the touchpad is "by design, as the unit would have to be sent back to HP to reenable it." Complete nonsense. Just plug in a USB mouse, but you have their position on the matter.

I can disable the touchpad if I use an external mouse, while the external mouse is present. But this isn't what I want to do. I want to be able to just use this computer as is without having to pull out a mouse every time I wish to use it and to be able to disable and enable the touchpad at will with a simple keystroke.

My gut feeling is that there is a way to make it possible to disable/enable this touchpad in the manner I wish to do so, but that this solution is deep and beyond my current abilities. I've studied the INF files and registry entries associated with the touchpad drivers. But nothing stands out as obvious.

I've installed and tried out every touchpad manager utility, without success. One way or the other, they either don't work as desired to limit touchpad interference or they go too far in the other direction, forcing me to wait longer than is comfortable for the touchpad to start accepting input again. There is one utility that lets you assign a keystroke to disabling and enabling the touchpad, but it doesn't recognize my touchpad as being compatible with this feature, possibly for the same reason that devcon can't find it when I try to disable it.

I've done all my homework on this. I'm at my wits end. I'm willing to go deep and fiddle with the internals; I just need to know how to do so.

20
  • (1) There are reports that with the Touchpad driver 19.3.4.193 from MSI website disabling does work. If this helps then automatic driver updates can be blocked. (2) This solution might work but requires reboot.
    – harrymc
    Sep 14, 2019 at 10:55
  • harrymc, I considered this, but wasn't sure the driver version in question--a full year and a half older than the driver on my system--would support the full range of gestures that the ClickPad technology allows. Honestly, I just want to be able to tweak something in the registry to allow for disabling/enabling the existing driver. Seems like it should be possible. After all, the registry is where everything is managed. My hope is that someone in the Stack Exchange universe knows how to do this. This would, after all, be a "super user" worthy response. Sep 15, 2019 at 6:39
  • Maybe you can disable it through the registry have a look here: mikemstech.blogspot.com/2011/11/… Sep 23, 2019 at 11:30
  • (1) Have you tried renaming registry key HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics and reboot? (2) Check if Control Panel > Mouse has a ClickPad tab where you can disable it. (3) There is the dirty trick of forcing an incompatible driver that will effectively disable the clickpad, but this requires reboot on any change.
    – harrymc
    Sep 23, 2019 at 12:39
  • 1
    use a autohotkey script, see here : superuser.com/questions/1258852/disable-mouse-using-a-key Sep 26, 2019 at 12:52

6 Answers 6

0

EDIT:

Now that I actually read the whole question (thanks for pointing out what I missed), one more dumb thing to try:

(3) https://support.hp.com/us-en/document/c03882926

  • HP says that the enable/disable is under "Mouse Settings" / "Additional Mouse Options"; they added a special tab to the option dialog.

Wrong Answers

Sorry if I missed it already in the responses, but I had two dumb things you could try:

(1) I usually can disable my touchpad in BIOS, or

(2) HP says some of them have an "on/off switch"[see below] (but usually not yours).

If this answer doesn't help I'll just delete it.

4
  • He indicated in his question he needs to disable/enable on-the-fly via shortcut keys so #1 doesn't help. #2 very good idea, but can't help him as he already indicated it doesn't have hotkey or switch
    – gregg
    Sep 27, 2019 at 18:21
  • Yeah it's a tricky one. Crazy thing is, I know there's a solution. It's just deep and clearly not well-known. I basically have to hope that an engineer from Microsoft stumbles across this question who knows the internals of the registry and how it is used to allow/disallow a driver to be disabled on the fly. Sep 27, 2019 at 20:43
  • What's especially odd about this problem is that if you plug an external mouse in, you have the option to disable the touchpad while the mouse is present. So this means the software machinery for disabling/enabling the touchpad is already here! It's just a matter of figuring out how to access and customize it. Sep 27, 2019 at 20:48
  • I take it #3 above also did not work?
    – AenAllAin
    Sep 30, 2019 at 18:37
0

The following are some ideas for disabling the clickpad. I can't test them since I don't have the right hardware and I don't know which of them require a reboot to take effect.

Destroying the driver

You might be to install an old version of the driver that lets itself be disabled. You will need to delete the current driver from Windows.

You could also delete the device and the driver, and let Windows supply a generic driver which you might be able to disable.

Installing the wrong driver for the clickpad can also effectively disable it:

  • Start Device Manager
  • Navigate to: Mice and other pointing devices > Synaptics SMBus ClickPad
  • Right-click and choose Update driver
  • Click Browse my computer for driver software
  • Click Let me pick from a list of available drivers on my computer
  • Click any other displayed driver than the right one
  • Click OK as demanded

A reboot might be required, but try to see if it works without it. If in reboot Windows reinstalls automatically the Synaptics driver, you might need to disable driver updates to the device as described in this answer of mine.

Increase Smartsense timers

I didn't find good documentation for Smartsense, but here is what I did find. The idea is to increase the timers for disabling the clickpad while you are typing:

  • Start regedit and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Defaults
  • Enter a large value for all PalmRT and all PalmKms entries. I suggest using 32767 (hex 7FFF) which the largest 16-bit integer.
  • Use regedit to search for all other occurrences of PalmRT and do as above
  • For clickpad settings not to be deleted after a restart:
    • Navigate to KEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Install
      and change DeleteUserSettingsOnUpgrade from 1 to 0
    • Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl
      and change RestoreAllDefaultsfrom from 1 to 0
1
  • I'm going to try tweaking the values for PalmRT and PalmKms at some point. I'll want to back up the key before doing so and I want to be in the right mindset and have the time available to play around with it some. There are dozens of these entries if I recall--maybe more. So I'll want to be able to restore defaults on the fly. I don't know if the changes will take effect without having to restart the driver, however. If they can take affect without having to restart the driver, then I should be able to use a script to switch between default and custom settings. We'll see. I'll let you know. Oct 3, 2019 at 21:33
0

Your driver version is 19.5 and mine in 19.3, So I am sure you must be having the same menus as my synaptics driver.

"the software used to manage it tries to prevent unwanted taps, moves, selections, etc. while typing, it's less than adequate."

If this is the issue, there is an easy solution, try the following:

  • Make sure your Synaptics tray icon in taskbar is enabled (to enable: Control Panel > Mouse > Device Settings/ClickPad Settings Tab > Tray Icon > Select Static tray icon in taskbar.)
  • Then right(or left) click on the Synaptics Pointing Device icon, and then uncheck the Tap to click option. You can also uncheck Enable Gestures.Give it a try.

  • And if this does not solve what you are trying to do, then right click on the Synaptics Pointing Device icon,and then select Pointing Device Properties, Under the tab Device Settings/ClickPad Setting, Select the name Synaptics Touchpad and click Disable.

  • You can also decrease the sensitivity of the Touchpad/Clickpad, Search windows for Touchpad Settings > Touchpad sensitivity > Select Medium or Low.

  • The latest available touchpad driver for windows 10 version 1903 on the HP Support site is 19.5.35.41 sp96678, how is yours 19.5.35.47? Through Windows update? Then completely remove the current(.47) driver and try installing this(.41) one and maybe the option to disable will be clickable.

1
  • My driver was actually updated by HP recently, a little before posting this, but all the same issues existed with the previous version. I'm actually inclined to use the most current driver. I just want to be able to tweak something in the driver INF files or in the registry to allow the driver to be disabled the same way, say, the touch screen functionality can be disabled. Oct 3, 2019 at 21:27
0

I have an unorthodox answer. Write a little python3 pynput script which repeatedly moves mouse curser to a dead position in every millisecond, this way it will be stuck there. Assign a keyboard shortcut to disable and enable it.

https://pynput.readthedocs.io/en/latest/mouse.html Check Controlling the mouse , and find listening keyboard inputs combine them.

While installing python3 do not forget to put a tick to "add to PATH". You can use visual studio code to code. pip3 install pynput will install the library

also in python you can use win32api cononically called pywin32 or wmi to disable clicks in same code.

https://stackoverflow.com/questions/8794447/put-interface-down-in-windows-with-python

-3

Well, if you mean a software answer, this is not going to help you. With an Arduino Nano and the V-USB library, you can make the Arduino nano bit-bang as a USB HID device(i.e. pretend to be a mouse) on demand. Hook up a push button and you are set. Although you still need to have external hardware, this can be made to be just about the size of a USB thumb drive, and also just 1 button click.

4
  • 1
    or.. he could just plug in a 2 dollar tiny mouse usb dongle without a mouse attached to it.. if he doesn't want to plug in a mouse.. why the heck would he want to invent Frankenstein's monster and plug that in instead? Sep 27, 2019 at 18:14
  • Well it can be smaller.
    – he77789
    Oct 1, 2019 at 5:04
  • Smaller than this? Oct 1, 2019 at 17:32
  • Well you do a plug/unplug operation. Not a click.
    – he77789
    Oct 2, 2019 at 14:36
-3

start>change mouse settings>additional mouse options>touchpad>disable

OR

Double-tapping the upper-left-hand corner of the TouchPad enables or disables the TouchPad

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.