I want to give a user remote access to files in gcs via sftp. I am thinking of doing this by granting access to a folder hosted on a google compute engine vm instance (basically want to setup an ftp server on google cloud).

I followed the steps below:

  1. Create vm instance (centos7 micro)
  2. Add username/password in terminal of vm instance
  3. edit sshd_config file to uncomment "PasswordAuthentication yes"
  4. In filezilla connect to sftp:$username@$externalip with username and password from step 2. No ssh private key supplied

When I do this I receive the following connection error using filezilla :

No supported authentication methods available (server sent: publickey,gssapi-keyex,gssapi-with-mic)
  • It looks like the server is running a SSH server, not a SFTP server.
    – jww
    Sep 15, 2019 at 2:43
  • @jww OpenSSH (which uses sshd_config mentioned in the question) is both SSH and SFTP server. While it's possible to misconfigure the OpenSSH in way that SSH works, but SFTP does not, it's not this case. The connection fails in an authentication phase already, a way before an SFTP channel is started. Sep 15, 2019 at 13:27
  • @user11020868 What is "correct"? You have set up an SFTP server. You are connecting with SFTP protocol in FileZilla. Your question is not about FTP. If wanted to setup FTP, you are on a wrong track. Sep 15, 2019 at 13:27
  • Apologies - yes in this case it is sftp. Do I need to supply a key to filezillla or is username / password enough ? Sep 15, 2019 at 13:41
  • SFTP works even with password. Make sure you have restarted sshd, as already suggested by @Gary. Sep 16, 2019 at 5:52

3 Answers 3


To, connect via SFTP -- First, you have to generate SSH keys(public keys and private keys) on your local computer, after that, you have to add the public key to Google Cloud metadata and configure Filezilla with the private key. Here is a details blog of siteyaar which I find helpful.


Unlike SFTP, Google Cloud VM(S) does not come with a pre-configured FTP server. To connect via FTP you have to set up an Ftp server using vsftpd. Here another blog of siteyaar which also helps you in this regard.


  • Please note if you want to promote or recommend your own product/blog, there are some guidelines in place for doing so. Following them will help you avoid giving the impression that you're spamming. Could you please edit to explicitly state your affiliation? Thanks. (If you're not actually affiliated, it may be worth mentioning that as well.)
    – DavidPostill
    Nov 29, 2019 at 19:39
  • This should be the accepted answer in my view
    – Nam G VU
    Nov 16, 2021 at 10:29

GREAT question and I stumbled here. We tried the some google partner and it was going to be $100/month THEN had trouble even setting it up. THEN, we tried just centOS install and ran into some similar issues that you are reporting BUT then we found


and I did an nslookup so I could map sftp.{ourdomain}.com to their ftp server to look like our sftp and then they have a mapping to drop into google cloud which we will definitely be using. setup: FAST...it was nice

THOUGH, I have not setup the google cloud connector and we are just using their storage for now. we plan to connect it to google cloud later.


You can also try SFTPCloud. It's a managed solution that allows you to access Google Cloud Storage via SFTP. You can manage from a web dashboard the SFTP users, set bandwidth & storage quotas, key-based authentication, create multiple SFTP servers (each one can have a storage from a different provider), view the active connections in real-time, etc. Maybe it will help other users searching for a simple-to-use solution to access GCS via SFTP.

  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Sep 8 at 20:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .