Just as the title states, I am encountering a very strange issue with USB transfer between my PC (Win10) and android devices. While I am able to transfer files from my android devices to my PC, I am unable to move files to them (the transfer gets stuck at 0%). I've tried different cables, USB ports, heck even multiple devices (OnePlus 6, Xperia XA Ultra and Galaxy S9) and the same problem crops up across all of them. I am beyond frustrated and any help would be much appreciated.


Did you set the USB mode to file transfer? When you connect your phone via USB, you should get a notification on the phone (phone has to be unlocked), choose "Use USB for: File Transfer" Then you should be able to transfer files. Make sure the directory you are trying to write to is not write protected.

You can also try to enable developer / debugging mode if it doesnt work.

More information can be found here:


  • Yes, I have tried both setting the mode to File Transfer and also USB Debugging Mode but is met with the same problem. – user4932354 Sep 17 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.