0

Just started getting Maven deploy-file errors from Java (cannot copy directly from afflicted system, so there are probably typos):

[DEBUG] Filed to dispatch transfer event 'PUT PROGRESSED http://maven-upload-name <> source-file-name'
IllegalArgumentException: Progressed file size cannot be greater than (deploy idea of file size) > (actual file size)

What is particularly heinous about this error is that the deploy-file plugin then re-tries to upload the file -- and for some reason increases its idea of the file size by 1048 bytes. It keeps doing this and doing this and doing this, generating zillions of lines.

This is on Windows, and it matters not if I run this in Jenkins, from Windows command line, or Git Bash. If I run it from the command line, ^C can't stop it -- I have to close the window and tell Windows "Yes, I know there's a command running; close it anyway!" In Jenkins, I have to kill the job (assuming I'm aware of the problem).

mvn's -X flag gives the following start to the stack trace (again, typos are mine):

org.apache.command.lang.Validate.isTrue (validate.java:158)
org.apache.maven.cli.Transfer.AbstractMavenTransferListener$FilesizeFormat.formatProgress (AbstractMavenTransferListener:195)
org.apache.maven.cli.Transfer.ConsoleMavenTransferListener.getStatus (ConsoleMavenTransferListener:117)
org.apache.maven.cli.Transfer.ConsoleMavenTransferListener.TransferProgress(ConsoleMavenTransferListener:90)
<and a lot more>

What is going on? What can I do about it? I can't find anything about this on the Maven site or StackOverlow (or similar sites).

And why does deploy-file keep re-trying and generating enough output to fill a disk? That alone should be considered a bug!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.