3

I have an oscilloscope from Velleman (PCSU200). Used it about a year ago, then stuck it a drawer until I should need it again.

When I retrieved it again about a month ago, the PcLab200-software was unable to detect the hardware, but the oscilloscope showed up in the device manager. The details for the driver looked a bit odd, however (see pic).

When I remove the old driver, the computer usually installs one when the oscilloscope is plugged to the usb, but the driver properties don't look good (see pic) and the PcLab software fails to find the oscilloscope.

Stuff already tried:

  • Just updating the drivers from devmgmt, but windows thought the version I had was the best alternative.

  • Downloaded the PcLab200-setup from the makers homepage (https://www.velleman.eu/support/downloads/?code=PCSU200) to get the latest and greatest drivers, unplugged the oscilloscope, removed the old PcLab200-software (the drivers are bundled with this software) and reinstalled PcLab200. No luck.

  • Uninstalled the old drivers and tried installing the new ones I got from the Velleman homepage. Now the computer complained that the inf-file was missing a required section.

  • Removed PcLab-software, removed the regedit entry for the PC Oscilloscope and then reinstalled the PcLab software. Looks the same, I can see no obvoius problems with it, problem persists.

  • Uninstalled the driver, rebooted the computer, reinstalled the driver. Stil same result

  • Run chkinf on the inf-file. It gives two warnings ((W22.1.2212) No Copyright information found. and (W22.1.2215) Class CustomUSBDevice (ClassGUID {a503e2d3-a031-49dc-b684-c99085dbfe92}) is unrecognized., but I kinda doubt that this is the issue. The GUID can be found in the registry. Tried to paste the report, but perhaps that made the question too long?

  • I have also called the seller, mailed the producer and posted on the producers forum. There was some nice person on the forum who tried to help, but didn't get very far. The producer answered my mail after a week with a fairly standardized "have you tried downloading the software from the homepage and installed it correctly" (which I had explained that I had already tried in my first mail). Have mailed them a few more times, but they don't seem very interested in support.

Driver properties (according to devmgmt), error message upon trying to update the driver + inf-file properties

  • +1 upvote for a great question, you've done your research and checked all the obvious things (and then some!!!) – spikey_richie Sep 17 at 12:14
  • Did you restart the PC after uninstalling the software and drivers, then try re-installing the package? It is important you do it this way. – Moab Sep 17 at 13:34
  • @Moab - I have uninstalled the driver, rebooted and then reinstalled it, not the PcLab200. I can try that later today just to be thorough, but since the issue seems to be the driver rather than the software, I kinda doubt it will make a difference. Thanks for the suggestion! :). – Camilla W Sep 17 at 15:00
0

Your driver is the latest from Velleman.

All I can add is that on the post Pcsu200 windows 7 driver, in the last entry was posted a driver for Windows 7 32-bits which you could try.

I have checked the download on VirusTotal and no viruses were found.

  • You are my hero! With these drivers, it suddenly seems to work :). The driver properties look quite strange still (now it claims that Microchip made them), but the PcLab finds the 'scope and it produces seemingly reasonable measurements... more testing will ensue, but at least something happens now :D – Camilla W Sep 17 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.