2

I'm trying to post-date my Windows 10 system by one year. I go into the Windows menu to change date and time. I press 'Change', it opens a window, I choose 2020, I press 'Change', then the clock changes to 2020 – and then it reverts to 2019 less than 30 seconds later. The system has no internet or network access, and all visible options in the window are disabled.

  • “Set time automatically” is OFF
  • “Set time zone automatically” is OFF
  • “Adjust for daylight savings time” is OFF

How can I post-date my system clock by 1 year?  Is some other piece of software altering my clock maybe, or have I encountered a flaw in Windows?

This Windows 10 system is running as a virtual machine in VirtualBox.

  • 1
    Does it revert back to the current date and time if you make a small change, like setting the date to 10:10am on 10/10/19? – drivec Sep 17 '19 at 18:37
  • I tried altering it to 3 months in the future (still in the same year) and it still reverted it. – user1091162 Sep 17 '19 at 18:38
  • Have you tried running Command Prompt as an admin and trying "date 09/17/2020" ? – drivec Sep 17 '19 at 18:41
  • I tried that too (command prompt as admin) it did the same thing. Changed it for like 10 seconds, and then it reverted. I also tried changing the hour forward by just 1 hour, and it still reverted back. – user1091162 Sep 17 '19 at 19:00
  • 2
    Have you tried changing the BIOS clock? – BloodPhilia Sep 17 '19 at 20:00
1

Since you are using a VM with VirtualBox, your VM will automatically sync with the host computer. You will need to disable this time sync feature as written in the VirtualBox manual.

You can disable time sync by doing the following.

  1. Find your VM's .vbox file on your host machine. (You can do this by right clicking the VM in the main VirtualBox window and selecting "Show in Explorer" or "Show in Finder".)
  2. Shutdown your VM and confirm VirtualBox is no longer running.
  3. Make a backup copy of this .vbox file.
  4. Open the original .vbox file in a text editor.
  5. Under the <ExtraData> tag put the following line: <ExtraDataItem name="VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled" value="1"/>
  6. Save the text file and close the text editor.
  7. Start VirtualBox and your VM.

You should now be able to change your VM's date and time independently of your VM host machine. If you ever want to sync time with your host machine again, remove the line or set the value of this line to value="0"

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.