Windows XP decided when I logged on that because the network was unavailable at the time that two of my network drives should be mapped to my local drive so that data would be saved.

All well and good but I need it to stop now so I can use my network drives again. I can't find anything relating to the feature but I can't remember the specifics of the message it gave me when it started this operating mode and Google searches for the sort of terms above leads me to a slew of irrelevancies.

Any ideas? Thanks.

Here's an ASCII version of the Explorer window for "My Computer"

Hard Disk Drives

LocalDisk1 C:
LocalDisk1 I:
LocalDisk1 L:

Network Drives

NetDrive1 G:
NetDrive2 X:
NetDrive3 Y:

I expect:

Hard Disk Drives

MyDiskName C:

Network Drives

NetDrive1 G:
NetDrive2 X:
NetDrive3 Y:
NetDrive4 I:
NetDrive5 L:
  • i've never seen the behavior you describe. did you have offline caching enabled perhaps? i've never used it so i don't know if it would behave like that or not. – quack quixote Jun 3 '10 at 9:25
  • Offline caching seems to be related only to shared folders. These aren't shared folders - they're network mapped drives where Windows is now shadowing the C: drive instead of using the network. I haven't found anything that indicates that it should be doing anything in the "Offline Files" section of the Group Policy manager. – cyborg Jun 3 '10 at 10:01
  • I may have to just log in/out again to resolve this and get a note of what it actually told me to see if I can find anything and reproduce it. – cyborg Jun 3 '10 at 10:28
  • explain how you "map a network drive" that "isn't a shared folder"? if you're using standard Windows Networking, it uses CIFS/SMB regardless of whether you've mapped the share to a drive letter or not. now, if you're using iSCSI or something else to provide your drives, that's different. maybe it would help if you specify what's providing the network drive? – quack quixote Jun 3 '10 at 13:27
  • It's a samba mount. It's not a shared folder in the sense that it's not a shared folder on the local drive, whilst it's obviously ultimately a folder on another drive - in this case potentially unix as well as NT boxes. – cyborg Jun 3 '10 at 13:52

What you describe is impossible: When the network is down, mapped network drives are simply not available. They are certainly not re-mapped to anything else.

If your network shares were destroyed for some unknown reason, just remap them again using other drive letters.

If your problem derives from offline caching, you can use Windows Explorer to disable the cache by right-clicking the shared folder and press Properties. On the Sharing tab, press the Caching button and clear the Allow caching of files in this folder box.

  • Possible or not it's what Windows did. I would reset the mappings except now the drive letters aren't available anymore as they're shadowing the C: drive. It's not a shared folder but an entire network drive that has been reassigned from being a network drive to shadowing the C: drive. Unfortunately since it's not shared there's nothing under Caching that helped. – cyborg Jun 3 '10 at 9:53
  • @cyborg: What happens if you delete such a "network" drive? (make sure first that you have backups for your data) – harrymc Jun 3 '10 at 10:13
  • Can't delete the drive from Explorer - unless you mean something else? – cyborg Jun 3 '10 at 10:20
  • @cyborg: Where does it appear : Network Connections or Windows Explorer? – harrymc Jun 3 '10 at 10:35
  • 1
    @quack quixote: Caching is on the client side and can be disabled by "net share \\servername\sharename /cache:no". – harrymc Jun 3 '10 at 16:11

Under Control Panel go to Administrative Tools -> Computer Management. Click on the Disk Management node under Storage in the tree on the left side.

Now right click on the C: drive listed under your disk and select Change drive letters and paths. this should allow you to remove the shadow drive letters.

  • Unfortunately the shadowed drives aren't showing up there. Windows won't let me doing anything with the C: drive since it's mounted. – cyborg Jun 3 '10 at 10:04
  • @cyborg: have you tried forcibly dismounting those drive letters with the mountvol command? – quack quixote Jun 3 '10 at 13:29
  • Tried that on the C drive ... not a good idea. One reboot later and the network config has sorted itself out but now I'm left in the dark as to WTF was going on :( – cyborg Jun 3 '10 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.