0

I have Windows 10 and I previously had installed Zorin distro and worked fine. Then I deleted from Disk Management in Windows the previous partition where Zorin (Ubuntu-like distro) was installed and I installed Linux Mint 19.

The issue is that now when I reboot the Grub menu for Dual Boot is not present, instead appears the message

               GNU GRUB version 2.02

Minimal BASH-like editing is supported...
...
...

grub> _

I've followed some step by step guides trying to fix the MBR or Grub but didn't work.

I've already tried to fix the grub using a live USB of Linux Mint and running the commands below

sudo mount -t ext4 /dev/sda7 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /dev/pts /mnt/dev/pts
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt

grub-mkconfig -o /boot/grub/grub.cfg

sudo grub-install /dev/sda

The I tried fix the MBR from a Windows 10 installation DVD running these 2 commands but that didn't work either, even when the commands where executed successfully.

bootrec.exe /fixboot
bootrec.exe /fixmbr

I can login into Windows10 only going to boot options and selecting "Windows Boot Manager" but when I let the normal booting without pressing F12 the Minimal BASH-like editing is supported... window appears.

What I need to do in order to set a working dual boot menu? Thanks

0

I was able to fix the Windows boot so far following this steps from this site. I hope help someone in the future.

Run command prompt from Windows installation DVD
diskpart
sel dis 0
sel par 1
del par override
cre par EFI
for fs=FAT32 quick
assign letter=T
exit
bcdboot C:\Windows /s T: /f ALL
exit

Then reboot the computer
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.