2

I'm scratching my head on a nvidia drivers problem in debian 10. I did a fresh install of debian 10 on a new laptop. This laptop have an Intel GPU and a Nvidia GTX 1650.

I followed some explanation here or here to install the drivers and to blacklist nouveau to use only the Nvidia GPU (as explained in the first link). It means the following :

  1. vim /etc/modprobe.d/blacklist.conf :
    blacklist nouveau
    blacklist lbm-nouveau
    options nouveau modeset=0
    alias nouveau off
    alias lbm-nouveau off
  1. vim /etc/default/grub and add the nouveau.modeset=0 part :
    GRUB_CMDLINE_LINUX_DEFAULT="nouveau.modeset=0 quiet"
  1. vim /etc/modprobe.d/nouveau-kms.conf :
   options nouveau modeset=0
   GRUB_CMDLINE_LINUX_DEFAULT="nouveau.modeset=0 quiet"
  1. sudo update-initramfs -u
  2. reboot
  3. sudo apt install nvidia-driver nvidia-settings nvidia-detect

After this, I'm still booting with nouveau.

But I just understood (thanks to this post) that even with the blacklist of nouveau, nvidia drivers are installed but not in use.

Here is my lspci -nnk | grep -iEA2 'vga|3d' :

00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 630 (Mobile) [8086:3e9b]
    Subsystem: Dell UHD Graphics 630 (Mobile) [1028:0924]
    Kernel driver in use: i915

01:00.0 3D controller [0302]: NVIDIA Corporation Device [10de:1f91] (rev a1)
    Subsystem: Dell Device [1028:0924]
    Kernel driver in use: nvidia

So it looks that the nvidia drivers are correctly installed but not in use.

Also, the nvidia-settings command or the gui launcher for nvidia configuration does not work. In cli, I have the following error which makes me very sad :

ERROR : Unable to load info from any available system

How can I switch to nvidia drivers and never use anymore nouveau ?

Also, I tried the proprietary drivers for GTX1650 but when I install it, I boot on a freezed login screen (not able to do anything). At this point I was not able to rollback and reinstalled buster

For the moment, if I watch an hd video, the video seems laggy and I'm sure it would not be a problem with the proper driver.

Thanks for your help!!

0
0

Well, I did not found the solution to always be on the nvidia GPU. But after some research I find a good way to jump between the two, using bumblebee which is the recommended package to efficiently manage multiple gpus. I did the following on a fresh install :

echo "blacklist nouveau" > /etc/modprobe.d/blacklist-nvidia-nouveau.conf 
echo "options nouveau modeset=0" >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf 
sudo systemctl set-default multi-user.target

Reboot (sudo systemctl reboot), you should so be in cli and not in gui mode. This is the moment where you install specific nvidia-driver and bumblebee which will manage the two graphic cards :

sudo apt install bumblebee-nvidia nvidia-driver-libs-nonglvnd nvidia-driver bumblebee primus
sudo systemctl set-default graphical.target
sudo systemctl reboot

You should be in graphical mode then. Not sure if the nouveau blacklisting is necessary but it seems to work fine this way...

Also, on a Dell laptop, you can frequently have problems with the fans which are rotating way too fast even if the laptop is doing nothing (which can give you the impression that nothing is working fine). This is an other problem for whoch you can maybe find help using google. Personnally, I have not been able to find a ogod fan configuration yet on my vostro 7590...

1
  • 1
    I had to run sudo update-initramfs -u for the blacklisting to take effect,
    – varnaud
    Aug 31 '20 at 11:56
0

I have the same graphics card like you, I guess it's a laptop(mine is a XPS 15 7590). And with Debian 10 for some reason X won't start, you get a black screen. I could work this out by creating an xorg.conf via nvidia-xconfig AND add hte PCI BusID for the nvidia card. After that X starts normal and u can use the full potential of the card for gaming etc. No need for blacklistig, switching gdm/lightdm/sddm or Wayland etc... Hope this helps!Please drop my a line if I should share my config file.

5
  • I have been dealing with this issue for weeks with the XPS 7590 and NVIDIA 1650 GPU. Would you mind updating your answer with a detailed description of how you got the card to work starting from scratch on a fresh install? I think it would help a ton of people including myself.
    – wuno
    Jan 11 '20 at 21:28
  • You wil need the nvidia 440 from experimental. Also a small adjustment for gdm. Add a file called optimus.desktop containing: [Desktop Entry] Type=Application Name=Optimus Exec=sh -c "xrandr --setprovideroutputsource modesetting NVIDIA-0; xrandr --auto" NoDisplay=true X-GNOME-Autostart-Phase=DisplayServer Copy this file to sudo cp optimus.desktop /usr/share/gdm/greeter/autostart/optimus.desktop and sudo cp optimus.desktop /etc/xdg/autostart/optimus.desktop .
    – paines
    Jan 12 '20 at 22:31
  • Last but not least: Then you have nvidia on-demand, meaning intel is running by default and fire up apps on nvidia with __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME="nvidia" __VK_LAYER_NV_optimus="NVIDIA_only" exec "$@". Hope it works for you.
    – paines
    Jan 12 '20 at 22:35
  • Thanks for the reply, so I am actually using ParrotOS which uses MATE by default. Is there any specific changes based on the desktop environment? Also one more questions, when I run lspci I do not get GTX 1650. Instead I just see NVIDIA Corporation Device 1f91 (rev a1. I was able to get nvidia-smi to output the correct device in the output showing driver 430 as the driver. But after a reboot nvidia-smi continues to say make sure your nvidia driver is installed and running and no longer shows the device information.
    – wuno
    Jan 12 '20 at 23:49
  • With Mate Desktop there is a n applet called mate-optimus-applet which you can use to switch the cards. Lscpi never show the correct card information, only nvidia-settings. The last issue you have: make sure that the nvidia drivers are loaded, e.g. in /etc/modules + update-initramfs -u. The on-demand thingy will not work with 430 as it was implemened in >=435 iirc.
    – paines
    Jan 13 '20 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.