15

I recently noticed that the reason my Wi-Fi was so terrible seems to be caused by plugging in my charger.

Here is a little video of it happening, trying to ping riot.de

Here is the ping when plugged in:

Here is the ping when plugged in

And here, when it isn't:

And here, when it isn't

What could be causing this issue ?

I tried updating my Wi-Fi drivers and resetting my power settings, to no avail. I am running Windows 10 and using a Dell Wireless 1550 802.11ac.

Here are the main power settings:

enter image description here

Just got similar result after testing it within the Windows sandbox (Which should put aside the problem behing cause by bloatware, right ?).

First plugged in, then not:

enter image description here

UPDATE

Tried a few other things:

  • Using a different network, (in this case, the school one), gave similar results
  • Pinging other website (youtube.com and reddit.com) gave similar results
  • Pinging someone else on the same network gave similar results
  • Using a new charger
  • Comments are not for extended discussion; this conversation has been moved to chat. – DavidPostill Sep 20 '19 at 17:50
  • Have you tried setting your power plan via group policy? And to rule it out, see if the problem persists when matching "on battery" settings to "plugged" ones, and vice versa? Windows 10's power plan doesn't play nice with user-modified plans, which is why I mention the group policy method to get it to not default back. – Arctiic Sep 23 '19 at 9:43
  • 2
    Low-tech suggestion: Wrap the cable in tinfoil. – harrymc Sep 23 '19 at 12:26
  • 2
    I suspect that this is caused by EMF interference caused by damaged hardware, too. To confirm that it is not a software / configuration fault you could boot a Linux Live Distribution from USB, like Manjaro manjaro.org/download/official/xfce and see if this happens there, too. You could also try to use another plug socket, select another WiFi channel and compare 2.4 GHz to 5 GHz WiFi to further isolate the problem. – dirdi Sep 23 '19 at 14:46
  • I will be trying tomorrow to boot with Linux to completely put aside the potential software source. If it does not work, I'll try an external wifi dongle. I also tested on both 2.4 and 5GHz wifi, and got similar results. – Treycos Sep 23 '19 at 15:56
2
+50

Since ethernet works fine, it is most likely some sort of interference with the wireless signal caused by the charger and/or the charging process. This can be the case if the charger (or the laptop components involved in the charging process) gives out signal interfering with the WiFi signal and or the antenna of your Wifi module within your laptop.

The second scenario is an actual interference of the antenna not introduced by an "outside" frequency (that goes through the air) but through interference that reaches the antenna through the laptop's circuits.

The third scenario, possible though unlikely is that Wifi signal is fine but the controller itself does not work properly when the Laptop charges.

Either way there is need of further testign to determine the acutall cause of for the source of the delay.

| improve this answer | |
  • I agree with the first paragraph (interference probably caused by charger or laptop charging components). But the second paragraph is unclear - I think you mean receiving some kind of outside RF signal thru the charger/charging cable, but as he's tried it at different locations that is less likely. Regarding the 3rd paragraph, to test for that problem, try using a USB wifi dongle and see if it also has the problem. – Velo Traveler Sep 28 '19 at 23:12
  • @VeloTraveler with the second paragraph I'm trying explain that the interfering signal can also be a signal transmitted through the wire within the laptop (which originated from one of the laptops component). – Albin Sep 29 '19 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.