1

I am really desperate. Since about 3 months I have a problem and could not find a solution yet. The problem first occured with a media server (direct access - no reverse proxy between) I am using.

The problem:

  • HTTPS connections are very slow (1s-5s) when accessing webserver (Apache2 and the one integrated into the media server)
  • Access is via DynDNS address (I do not use different urls when on the in- or external network)
  • Fast HTTPS when accessing from the internet
  • Fast connections via HTTP and SSH no matter the location (internal + external)
  • Apache is the webserver (Nextcloud) + reverse proxy (Gitea and media server)
  • The media server is reachable over the Reverse proxy and directly via IP + Port (Direct only HTTP since the reverse proxy). Setup the reverse proxy now because I tried to solve the problem using this (Remember: The problem first occured with the media server).
  • Browser does not matter, the device does not matter (I tested with IE, Chrome, FF and Edge on two Windows devices and FF + Chrome on Android)
  • So an example: I am at home (in internal network). I am opening two tabs on the same device in the same browser: One accessing via HTTP (blazing fast) and one over HTTPS (slow). When on the external network (access from outside) both HTTP and HTTPS are (almost) equally fast.

Software used:

  • OS: Ubuntu Server 14.04
  • Webserver: Apache2 2.4.7
  • SSL: Lets Encrypt with Certbot => Auto-Mode enabled for Apache
  • Client: Android and Windows 10

Symptoms:

  • In internal network the upload seems to be limited to 100 KB/s on HTTPS. Download: No limited seeable. The problem kicks in when you access a webpage on the apache2 which loads images or scripts in the background which takes more time.
  • DNS, TLS-Configuration and Blocked are the things taking up the time (not all three the same time) according to FF dev tools
  • Every request takes between 1s and 5s (!)

I ran out of ideas. Regarding the system updates: 1-2 days before the issue an occured during the update of openssl. But unfortunalty everything still worked so I did not save the logs. That's why I assume openSSL or some other ssl libs are the problem. I really hope you guys can help me.

To come to some final questions:

  • Did you ever experience such a weird error/misbehaviour or know what might be the problem and how it can be solved?
  • Is everything okay with my ssl libraries/open ssl installation?
  • What is the best way to "repair" a package (esp. OpenSSL)?

This is was previously asked here by me. I did not know home questions are not allowed there. But what became clear from this is: If I access the server directly via e.g. https://<localip>/nextcloud the connection is fast. Ofc I have to ignore a lot of ssl warnings.

Here are the packages (in case you want to know) with ssl in its name. If you need more information please let me know. I can't update my Ubuntu installation as some required drivers would break. I will make a full backup/migration on a new server next year, because of money.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.