0

Recently, when I copy seven digit numbers from Excel and paste them into Outlook or Word, it pastes them as scientific notation and not as the seven digit numbers that I see them in Excel. I have tried changing format in Excel from "Number" type to "Text" or "General" but it does not seem to matter.

When I paste, I can right click and choose several different methods of pasting, but the only two that preserve the numbers are paste-as-image (which defeats the purpose) and paste-as-text (which eliminates the table format in the destination application).

How can I paste in these numbers and not have them go into scientific notation?

Thanks!

1
  • Have you checked the Paste options? Does it set to “Keep Source Formatting”?
    – Perry
    Sep 23 '19 at 6:39
1

Happened with me once...for me pasting into notepad first did the trick. Also try Ctrl + V in word

Which version of word and excel are you using are they both same ?

0

A few suggestions for you to try out:

1) Copy from origin cell and paste into any other unused cell via paste-as-value, then copy and paste from that cell to desired external program.

2) Use, e.g., =text(a1,"0,000,000") to format the cell (can also try step 1 afterwards)

3) Try custom formatting through the context menu (Ctrl + 1) and use, e.g., 0,000,000

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.