0

So I just installed MPD together with MPC and NCMPCPP but I can't get it to work. There is 1 song in the database, according to NCMPCPP (Show server info) but there are no Artists or Albums. I downloaded a song from YouTube using youtube-dl-mp3, but it doesn't show up. When I run mpc play it says volume:100% repeat: off random: off single: off consume: off (I don't know if this is right or not), and when I run mpc current after that I get no output. No song is playing. Here is my mpd.conf file:

db_file "~/.config/mpd/database"
log_file "~/.config/mpd/mpd.log"
music_directory "~/Music"
auto_update "yes"
bind_to_address "127.0.0.1"
audio_output {
    type "alsa"
    name "HD-Audio Generic"
    device "plug:dmix"
}

I'm not 100% sure "HD-Audio Generic" is correct, I got it from alsamixer (where it says Card: <sound_card> at the top).

0

Okay, so I found the solution: mpc add "$(mpc ls)". I completely forgot to run this command - my bad.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.