1

First of all:
Yes, I have read countless threads for hours on the issue presented in the title here and related issues.

On running my very first example app with Android Studio on Windows 10, I get the exact output:

Initializing gradle...
Resolving dependencies...
Running Gradle task 'assembleDebug'...
Built build\app\outputs\apk\debug\app-debug.apk.
error: closed
Installing build\app\outputs\apk\app.apk...
Error: ADB exited with exit code 1
Performing Streamed Install
adb: connect error for write: closed
Error launching application on SM G955F.

To fix this issue, I have tried solutions from all threads I could find. Amongst others I have:

  • Restarted Android Studio and run as administrator
  • Deleted the 'idea' folder and reopened the project

I have tried everything to create a new virtual device, but I can't make that available to my project - the button is greyed out.

0

After having tried a range of suggested solutions from stack threads, what made the difference was restarting my Win 10 system. Android Studio still doesn't seem to run stable and sometimes the option to choose a virtual machine is greyed out. But at first run after a reboot I was able to choose the two virtual devices I had created in Android Studio.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.