0

We wanted to migrate to SQL Server 2017. After we set up everything, we had a problem with the performance of the server.

After a few weeks, we found out that the SSIS packages requires exact 10 seconds more to run for each package.

This only happens if we run the package with the dtexec /fcommand and load the package from the file system.

We already tried to recreate the package and to run the dtexec with 32-bit and 64-bit. Nothing changed with this. However, if we run the package in Visual Studio or in the integration service catalog the package starts immediately and have a runtime reduced by the 10 seconds.

  • Are you running dtexec /f without any additional parameter? – Alberto Morillo Sep 27 '19 at 5:55
  • You using /f path only? – Alberto Morillo Sep 27 '19 at 6:04
0

Those extra 10 seconds may be related to the time it takes dtexec to validate all components of the package before executing it.

One thing you should validate whether packages are running on debug mode or log verbose mode. That should also explain the extra time needed. Try running the package as follows:

dtexec /f package_location /set "\Package.Properties[LoggingMode];2"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.