1

I suspect this may be the way that Windows 10 works, but would like it confirmed.

I would like Windows to prefer Ethernet when attached directly to my home router and be able to simultaneously use WiFi to connect to some single board computers which I use for development.

The important part is that if Ethernet is connected to my router then WiFi must not also attempt to simultaneously connect to it, only to other devices.

Is that how it works? If not, can I configure Windows 10 to make it so? Or should I be asking for an app to do it on software recommendations?

  • 1
    either ethernet or wifi, you will still be able to connect to the development single-board computers, unless you are connecting to them via their own SSID/Network. – JohnnyVegas Sep 26 '19 at 12:50
  • 1
    Can you please explain why wifi must not connect, when wifi is the only connection method on the devs? Even if it did, your application will still connect via ethernet to the router, then to the devs via wifi. – JohnnyVegas Sep 26 '19 at 12:54
  • Johnnym the SBCs do indeed offer their own access point with SSID The only rule is that wifimay not connect to the router. For Ethernet, I have a small router with VPN connecetd between the laptop & the teclo router. WiFi would go straight to the telco router without the VPN. Hope that makes sense. – Mawg says reinstate Monica Sep 26 '19 at 12:59
  • 1
    So for the wifi to NOT connect to the router, don't give the SBC's the SSID/Passwd. Your router also has wifi? Ask windows 10 to forget that network too – JohnnyVegas Sep 26 '19 at 13:46
  • 1
    @Mawg - I knew there was a missing protocol somewhere! – JohnnyVegas Sep 26 '19 at 14:54
1

For the wifi to NOT connect to the router, don't give the Dev boxes the SSID/Passwd. Your router also has wifi,so Ask windows 10 to forget that network too.

| improve this answer | |
  • D'oh! Why, oh why, oh why, did I not think of that. So obvious (slinks off in embarrassment) – Mawg says reinstate Monica Sep 26 '19 at 15:00
0

You can prioritise your Ethernet Network adapter, steps are shown below and they are extract from this WindowsCentral.com article.

On Windows 10, if you have a device with more than one network adapter (such as Ethernet and Wi-Fi), each interface receives a priority value automatically based on its network metric, which defines the primary connection that your device will use to send and receive networking traffic.

To change network adapter priorities using Control Panel If you want to change the order in which Windows 10 uses network adapters, do the following:

  • Open Settings. Click on Network & Internet. Click on Status. Click the Change Adapter options item.
  • Right-click the network adapter you want to prioritize, and select Properties.
  • Select the Internet Protocol Version 4 (TCP/IPv4) item. Click the Properties button.
  • In the "General" tab, click the Advanced button. Clear the Automatic metric option. In the "Interface metric" field assign a priority value for the adapter.

Quick Tip: The lower the metric number means higher priority, and a higher number indicates lower priority.

  • Click the OK button. Click the OK button again. Click the Close button.

Once you've completed the steps, Windows 10 will prioritize the network traffic depending on your configuration.

The only caveat using the Control Panel experience is that depending on your network setup, you may need to adjust the metric for the Internet Protocol Version 6 (TCP/IPv6) as well, if that's the protocol you're using. (Usually, you will be using the TCP/IPv4 protocol.)

At any time, you can revert the changes using the same instructions, but on step No. 9, make sure to check the Automatic metric option.

If this doesn't satisfy You, than Windows Firewall is a place to go, or maybe You will need something more(will need some more info).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.