0

If I restart the PC or disable then enable the network adapter, the network discovery is turned off. I have to turn it on manually. Is there a way to make it stay on? This is a wireless connection to a home LAN, a private network.

0

Windows lets you set each network you connect to as either a “Private” or “Public” network.

On Private networks, Windows enables network discovery features. Other devices can see your Windows computer on the network, allowing for easy file sharing and other networked features. Windows will also use the Homegroup feature to share files and media between your PCs.

On Public networks–like those in coffee shops–you don’t want your computer to be seen by others, though, or share your files with them. So Windows turns off these discovery features. it won’t appear to other devices on the network and won’t try to discover them. Even if you’ve set up a Homegroup on your PC, it won’t be enabled on a public network.

It’s simple, really. Windows assumes that your private networks–like your home or work networks–are trusted networks full of other devices you may want to connect to. Windows assumes that public networks are full of other people’s devices you don’t want to connect to, so it uses different settings. More on howtogeek.com.

Try the following:

  1. Open GpEdit.msc (Group Policy editor)
  2. Under Computer Configuration, expand Windows Settings folder inside it expand Security Settings and there You will see the Network List Manager Policies folder
  3. Right click on Network List Manager Policies folder and from the menu, choose "Show all networks"
  4. Inside Network List Manager Policies folder, on the right side, you will see your networks. To access their properties, right click on the desired network, and in the menu choose "Properties".
  5. Inside the Network properties window switch to the "Network location" tab and set the Location type to Private. If You are having a hard time to pinpoint the desired network, do this for all Networks that are shown there(it's not smartest thing to do, but it should do the trick).

enter image description here

Or You could do the following:

  1. Navigate to Advanced sharing settings: "Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings"
  2. Expand Guest or Public tab and select Turn on network discovery
  3. Click on Save changes Then your network dicovery will be turned on all the time(again, not the smartest thing)

enter image description here

| improve this answer | |
  • I did set it up as a private network. Yet, network discovery gets turned off quite often. – joehua Sep 27 '19 at 10:05
  • So your WiFi network stays in(declared as) Private profile, but her Network discovery setting switch to TURNED OFF state? – Leshy Sep 27 '19 at 11:11
  • Yes. I'm not quite sure when the Network Discovery would be turned off. Sometimes, when I boot up my laptop, it's already off. Sometimes, if I switched to another router and back, it's off. – joehua Sep 28 '19 at 5:43
  • I think my network adapter is at fault. From time to time, it'd disconnect from the network. – joehua Sep 29 '19 at 1:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.