24

When I installed the latest Windows 10 update I really liked the new screenshot / clipping tool that you can access with WIN+SHIFT+S.

Then after some time each time I use it the snipped picture gets copied to my clipboard, but the notification is missing and also there is no notification available in the Action Center, so I can not edit the snipped picture (sketch) in any way.

Is there a solution?

3
  • If it's get copied to clipboard you can paste it in MSPaint then edit or save it there.
    – Biswapriyo
    Sep 28, 2019 at 8:32
  • 3
    I know I can. But that was not my question - I would like to have the intended functionality back
    – TheMixy
    Sep 28, 2019 at 8:33
  • 2
    Go to Start, Settings, Apps. Scroll down to Snip and Sketch. Click in Advanced Options. Then click on Reset to repair / reset the App. Close out, restart and test. If necessary, uninstall it and reinstall from the Store.
    – John
    Sep 28, 2019 at 9:52

8 Answers 8

22

Had this happen to me in the last few days - tried the various options above, to no avail

Turns out it was just the App itself

(Which apparently https://superuser.com/users/1079976/john answered in a comment to the original question...my bad, missed it until after I'd typed this up)

  1. Went to Settings
  2. Apps & features
  3. Search/scroll for "Snip & Sketch"
  4. Click to expand
  5. Select Advanced options
  6. Click the Reset button

Settings - Apps & features

Reset button

2
16

Had the same problem worked fine for several weeks, then suddenly no more popups.

This fixed it for me:

  • Right click on the notfication center icon in the taskbar
  • Focus Assist
  • switch to Off (was set to 'Alarms only')
5
  • in the meantime I did a complete reinstall of the system (because of other issues) and since then it worked. If it stops working again, I'll try your solution. Best
    – TheMixy
    Dec 3, 2019 at 16:16
  • I don't know why MS keep messing about with our settings when they come up with something new. Thanks for this solution!
    – salvu
    Dec 2, 2020 at 14:08
  • Had notifications enabled, everything else looked good. This is what fixed it for me. Thank you!
    – tbox
    Apr 23, 2021 at 17:02
  • @Reinhard you Sir are a legend !
    – dtroy
    Jul 20, 2021 at 5:00
  • OMG, that worked! I forgot I had that on because NOTHING ELSE HONOURS IT!
    – Deanna
    May 5, 2022 at 9:38
11

To enable notifications from the Snip & Sketch Tool:

  • Start Settings
  • Click on System
  • Click on Notif‌ications & actions
  • Find Snip & Sketch and set it to On
15
  • It's set to ON and doesnt work
    – TheMixy
    Sep 28, 2019 at 10:21
  • That's not normal. Try to check Windows using sfc /scannow.
    – harrymc
    Sep 28, 2019 at 10:24
  • Done; I get this: Beginning verification phase of system scan. Verification 100% complete. Windows Resource Protection did not find any integrity violations.
    – TheMixy
    Sep 29, 2019 at 7:36
  • Maybe a registry change. For comparison, I posted my registry entry for Snipping Tool reg file for HKEY_CURRENT_USER\Software\Microsoft\Windows\TabletPC\Snipping Tool.
    – harrymc
    Sep 29, 2019 at 8:55
  • I think my setting are OK: AutoCopyToClipboard: 0x1 CaptureMode: 0x2 CapturePenColor: 0xff CaptureWindowVisible: 0x1 CustomPenColor: 0xff0000 CustomPenThickness: 0x40000000 CustomPenTip: 0x1 DisplaySnipInstructions: 0x1 DisplayURL: 0x1 FileFormat: 0 MarkupPen: 0x1 NotFirstRun: 0x1 PromptToSave: 0x1 SendTo: 0 ShowCaptureStroke: 0 ToolbarX: 0x8c ToolbarY: 0x45e IsScreenSketchBannerExpanded: 0x1
    – TheMixy
    Sep 29, 2019 at 18:01
8

I got the same problem.

My issue was because the Snip and Sketch tool was not installed on my Windows.

The Win + Shift + S shortcut works without it, but it only copy the scrot to the clipboard.

If you want to have the editing features (with includes the notifications) you have to install Snip and Sketch from the Microsoft Store:

https://www.microsoft.com/en-us/p/snip-sketch/9mz95kl8mr0l

2
  • I spent so much time "wasted" on the other solutions.. So simple a fix. My boxstarter script removed ALL non required windows apps on first boot I would have never found this solution without you. Many thanks!
    – wickdninja
    Jun 25, 2020 at 20:51
  • Thank you! that was it for me. Feb 8, 2021 at 23:46
8

Just throwing in my experience, looks like I had deliberately switched off notifications (on a global level), which unintentionally includes Snip & Sketch. The app was installed properly and such.

To quickly enable this right click the notifications icon/button in your taskbar then choose Turn on notifications:

Taskbar > Turn on notifications

Or open Windows Settings (press WIN+I), choose System, then Notifications & actions in the sidebar. There is a global toggle for notifications here to turn on.

Windows Settings > System > Notifications & Actions

1
  • 1
    I had this problem on Windows 11 and this is the fixed I used. The navigation on Windows 11 is a little different, once in the Settings app you need to navigate to System > Notifications and then make sure it is turned on. Under the "Notifications from apps and other senders" section also make sure Snipping Tool is set to On and it says "Banners" underneath the app icon. If it does not say "Banners" underneath the app icon, click the arrow next to the On toggle and turn on banners from the next page.
    – greg
    Apr 26, 2022 at 13:24
2

It's actually explorer.exe not working properly. If you restart it through the Task Manager it goes back to normal.

1
1

There are some things you could try before reinstalling Windows 10:

  1. Check if you turned Focus Assist on
  2. Check if some weird "system cleaning" software deletes Snip & Sketch
  3. (Requires restart) Reset Notification settings in registry

Check if Focus Assist is turned on

This is the most common case for the Snip & Sketch notification missing. Check the Action Centre on the bottom right corner of your screen. If there is a moon icon, then you have Focus Assist on. Simply right click, then you could turn it off in the pop-up menu.

Check if some weird "system cleaning" software deletes Snip & Sketch

This is the most common case for the missing notification if you are from Mainland China, as there are tons of PC manager software, or (某大数字60、某讯之类的)电脑管家, awaiting the chance of messing up your PC :)

Press Win+X then select Windows PowerShell, then type:

> Get-AppxPackage | select-string screensketch

Normally it would return a line reporting Snip & Sketch's package full name, like this:

Microsoft.ScreenSketch_10.2008.2277.0_x64__8wekyb3d8bbwe

If it is returning an empty line, then simply go to the store page, and download the Snip tool back.

Reset Notification Registry

Open regedit, then delete everything under \HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Notifications\Settings\Microsoft.ScreenSketch_8wekyb3d8bbwe!App. Don't forget to restart your machine!

0

I tried resetting the Snip & Sketch app, or uninstalling and reinstalling it, with no success. Keyboard shortcut didn't work, and if I manually started the app, it complained about a missing ms-screenclip association.

Finally fixed it by executing the following line in a Powershell:

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

Not sure what it's doing, looks like it forces all packages to re-register with the system, but after executing it, Snip & sketch works again (even its keyboard shortcut), and it also shows in Notifications and actions screen, something it didn't happen before.

Not the answer you're looking for? Browse other questions tagged or ask your own question.