0

After the 1903 upgrade to Win10, my Thomson NEO notebook started playing up - progressively complicated boot up. To cut a long story short, log files show that 4 ms files are corrupted.
Now, it boots either into Win10 recovery screen (simple one with only 2 options, one of which is OFF!), from which I can get to the cmd.exe and BIOS, or EFI CLI with exit to GRUB2 CLI. cmd.exe allows notepad.exe, but the CLIs do not have any editors - not that work, anyway.
EFI v 2.50 r 5.12 EFI Shell v 1.1.2
GRUB2 v 2.02~beta2-36ubuntu3.20
GRUB2 was installed a while ago whilst I was trying unsuccessfully to create a persistent live USB (see my question in askubuntu).
The disk is partitioned for a Linux multiple boot installation.
In BIOS, I have tried every combination of boot order, security settings, and I have triggered several "default settings" resets, to no avail!
The machine has only 2 USB slots and zero CD/DVD drives. I have one USB drive loaded with a live Linux installation - porteus, and another ready to reinstall win10 when I have finished salvaging my data. I had thought to speed up data recovery with the live USB, but ...

UPDATE: I successfully installed Win10 using MS media creator tool + format.exe. Loaded most of my executables off the Web, added a few bits of data from my recent recovery exercise. After less than 12 hours of operation, the screen froze forcing a hard reboot ... into the EFI Shell !!
This rules out the 4 corrupted files as a cause ... or does it?
I cannot rule out the 1903 update as the cause, because I did not check the version installed, nor did I check which updates were subsequently added. How would I find out now?
During the recovery exercise, a USB drive died. No USB drive was inserted when the freeze happened.
I am beginning to suspect a hardware or driver problem. But where to start and how to, with just the EFI CLI and the cmd.exe CLI to work from. Unless I use a live Linux USB?
UPDATE: I have just removed the "Segurazo Anti-Virus" virus, but still boot to EFI Shell. I was very disappointed that, although found by Avast, Avast could not remove it. I can only imagine that this virus came loaded with "Win-Zip Driver Updater" as everything else is from tried and trusted sources. Also removed! I am making avoidable mistakes now, just to complicate the issue!!

Any helpful suggestions would be most welcome.

Thanks.
Harvey.

4
  • Please remove one of your questions and focus your question on a single issue. Commented Sep 30, 2019 at 1:32
  • After a successful reinstall of Win10, and only 12 hours use, I am back to the EFI Shell, only now without GRUB2 as Windows reload required whole disk!
    – HarveyP
    Commented Oct 4, 2019 at 20:20
  • So the question now is, how do I go about diagnosing my problem in order to find out what to do about it?
    – HarveyP
    Commented Oct 4, 2019 at 20:29
  • And the title doesn't quite fit anymore, either!
    – HarveyP
    Commented Oct 4, 2019 at 21:17

1 Answer 1

0

To boot from your usb, you have to edit some settings in your BIOS settings. First you need to change disable fastboot in your BIOS-Settings. It is located under "BOOT". Then you have to disable "Security-Boot" in th "SECURITY"-Tab, otherwise you will get an error Message "Invalid boot signature". After this option is disabled as well, you should be able to boot into your Linux-Live

1
  • That did not work for Win10 until I had formatted the entire drive using the MS media creator tool + format.exe both from another machine. Now I have more problems, so that I do not even know the source of my troubles. If I install Linux now, the subsequent installation of Win10 for Mrs will erase Linux! Unless I use Wine, but then she would have to use Linux to get to it :-(
    – HarveyP
    Commented Oct 4, 2019 at 20:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .