0

I installed Apache Drill through the link in the Drill Documentation. Apache Drill works fine. I also installed and got Apache Superset running using docker. Superset also works totally fine.

But my goal is to integrate Superset and Drill together. The only tutorial I was able to find was a tutorial from Dataist. When following this tutorial they ask us to add a database.

Since I am running both Drill and Superset in my local machine they ask us to type drill+sadrill://localhost:8047/dfs/test?use_ssl=False as the SQLAlchemy URI. They ask us to test the connection by pressing test connection.

When pressing test connection I get an error message as follows.

ERROR: {"error": "Connection failed!

The error message returned was:
Can't load plugin: sqlalchemy.dialects:drill.sadrill", "stacktrace": "Traceback (most recent call last):
  File \"/home/superset/superset/views/core.py\", line 1755, in testconn
    engine = database.get_sqla_engine(user_name=username)
  File \"/home/superset/superset/utils/core.py\", line 132, in __call__
    value = self.func(*args, **kwargs)
  File \"/home/superset/superset/models/core.py\", line 911, in get_sqla_engine
    return create_engine(url, **params)
  File \"/usr/local/lib/python3.6/site-packages/sqlalchemy/engine/__init__.py\", line 435, in create_engine
    return strategy.create(*args, **kwargs)
  File \"/usr/local/lib/python3.6/site-packages/sqlalchemy/engine/strategies.py\", line 61, in create
    entrypoint = u._get_entrypoint()
  File \"/usr/local/lib/python3.6/site-packages/sqlalchemy/engine/url.py\", line 172, in _get_entrypoint
    cls = registry.load(name)
  File \"/usr/local/lib/python3.6/site-packages/sqlalchemy/util/langhelpers.py\", line 240, in load
    \"Can't load plugin: %s:%s\" % (self.group, name)
sqlalchemy.exc.NoSuchModuleError: Can't load plugin: sqlalchemy.dialects:drill.sadrill
"}

Can someone figure out why I am getting this error? Also if there are any other tutorials to follow which give a better idea on how to set up Drill and superset.

-1

I think you have to install the SQLAlchemy Dialect for Drill:

git clone https://github.com/JohnOmernik/sqlalchemy-drill
cd sqlalchemy-drill
python3 setup.py install 

(see https://superset.incubator.apache.org/installation.html#apache-drill)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.