So I installed an SSD on my laptop and I couldn't boot from it, nor another boot source ... It just shows a black screen with a small white cursor (fixed not jumping) while SSD installed....

What I tried with no luck:

  • formatted the SSD to NTFS
  • tried flashing windows and Ubuntu to a flash drive (with both options GPT & MBR; one each time)
  • cloned my HDD to the SSD (witch is working properly when I put it back)
  • disabled/enabled legacy mode on BIOS
  • changed boot order for both if the main list and secondary


  • the SSD works properly when tested with an external case
  • the SSD in, everything freezes, except bios menu
  • nothing inserted (nor HDD or SSD) booting working perfectly if I insert flash drive or DVD

What's the problem? 😅 Am I missing something?

PC: Asus K551LB SSD: Fujitsu F500s 512GB System: my fully functional HDD have Windows 10/Deepin dual boot

And I am trying both of them via flash drive (trying to boot with them)

  • 1
    Which OS and version number are you trying to boot from? Please click edit and add that to your question. Please don't use Add Comment; use edit instead.
    – K7AAY
    Sep 30, 2019 at 20:33

1 Answer 1


If Windows was installed in UEFI, non-CSM mode, with Secure Boot enabled, you must ensure those same options are set (UEFI with Secure Boot enabled, Legacy Boot disabled).

Once that's done:

  1. Boot a Windows Setup USB, as the WinRE partition on the disk likely won't boot since you cloned it, versus properly setting it up with the tools Windows natively provides to image a drive.
    1. Once the GUI Welcome window loads, press SHIFT+F10 to open a terminal
    2. Issue the following commands:
      1. bootrec /fixmbr
      2. bootrec /fixboot
        • This will likely fail, as the EFI boot partition is not accessible to users to protect it from malware or modification.
      3. bootrec /rebuildbcd
        • You will be asked to add a Windows install if one is found, please do so. If none are found, that's okay too.
  2. Reboot by closing the GUI setup Welcome window

  1. If Windows still does not boot, you will need to back up the C:\ partition on the cloned drive, unless you still have the original drive you cloned from, then:
    1. Boot to Windows Setup and open a terminal as in 1.1
    2. Issue the following commands:
      1. diskpart
      2. lis dis
      3. sel dis X
        • Where X is the # of the SSD
      4. clean
      5. convert gpt
      6. cre par efi size=100 offset=1024
      7. format quick fs=fat32 label=EFI
      8. cre par msr size=16
      9. cre par pri size=665 id=de94bba4-06d1-4d40-a16a-bfd50179d6ac
        • WinRE partition must have 320MB free (WinRE.wim is ~300MB in size)
      10. gpt attributes=0x8000000000000001
      11. If wanting:
        1. Rest of the disk as the system partition:
          1. cre par pri id=ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
          2. format fs=ntfs quick label=System
        2. To create additional partitions after the System partition
          1. cre par pri size=256000 id=ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
            • Creates a 250GB System partition, with the maximum size required being ~300GB if storing User Data directories on a partition other than C:\
              (i.e %UserProfile%\Documents, %UserProfile%\Downloads, etc.)
              which is recommended
            • Multiply the size you want by 1024 (i.e. 250*1024=256000)
          2. format fs=ntfs quick label=System
    3. Close terminal and proceed through Windows setup
    4. Select the 4th partition you created to install Windows to (partition from 3.2.11)
    5. Once setup reaches the "Installing Features" step, cancel the install
      • Setup can likely be canceled sooner, however, I'm not sure at which point it configures the EFI partition with the boot files, which is the only reason you're utilizing Windows Setup, since the EFI partition cannot be set up manually by the user on Windows 10.
    6. Properly Capture and Apply the System partition from the previous disk, utilizing the commands in this answer under Commands: Windows >=8, changing /Compress:Max to /Compress:Fast if you're not saving the captured image to an SSD.
      • Before applying the WIM of the system partition to the SSD, format the System partition on the SSD (partition #4 from above): format fs=ntfs quick label=System
  • Thank you so much for ur answer, i tried it step by step, still can't boot from usb while SSD in... Nb: i can lunch boot from usb flash drive normally if SSD is connected via USB... Even tried to install ubuntu in it like this .. succeed to install and boot from the SSD via usb .. but same problem if i fix it inside Oct 1, 2019 at 19:21
  • If I'm understanding right, It sounds like either the USB isn't configured with an EFI partition and formatted as FAT32 (for a USB to boot via EFI, it must be also formatted as FAT32), or something is enabled or disabled in the UEFI Firmware that shouldn't be. If the PC boots with the SSD after running Windows setup to have the EFI boot files properly copied over, but doesn't boot from USB, it's because the USB isn't configured to boot in UEFI, Secure Boot mode.
    – JW0914
    Oct 2, 2019 at 5:01
  • @AbdElhalimMerabet Personally, I would recommend reinstalling the old drive, booting to Windows to ensure it boots without issue, then boot to WinRE and Capture a WIM of the system partition. Once done, follow steps 3.1 - 3.4 in my answer, but this time, just to be certain, allow the Windows install to fully finish. Once the installer reboots, hard reset the PC & boot from the install media again to format the system partition and Apply the WIM you captured to the system partition on the SSD.
    – JW0914
    Oct 2, 2019 at 5:07
  • Why can't i just boot via a bootable windows flash drive and fresh install Windows 10 to the SSD ? ...Ii tried it with a normal HDD and it worked , even that the HDD is in RAW ... But with the SSD I can't boot any bootable media Oct 2, 2019 at 10:44
  • You should be able to, as, in this context, there's no difference between the HDD and SSD, provided the UEFI firmware is set to UEFI-mode, CSM / Legacy Boot disabled, and Secure Boot enabled. I would recommend troubleshooting this on a forum.
    – JW0914
    Oct 2, 2019 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.