1

I have 2 ISPs (One I am getting rid of -- Bell Canada).

The first provider is Bell Canada and they use PPPOE and is connected via DSL and it's a modem/router in one.

The second provider is Rogers Canada and is connected via Cable and it's a modem/router in one (Hitron CODA-4582U).

My original setup was as follows:

  1. Bell Modem/Router combo to the wall via phone-line (DSL) configured with Gateway functions on (it has Wifi - NOT BRIDGED).
  2. Asus RT-AC88U's WAN port to Bell Model/Router combo's LAN port.
  3. Asus RT-AC88U's configured using Bell's PPPOE username and password so the WAN IP is the public IP of the Bell router which is perfect!

This allowed me to have 2 networks (one from the modem/router combo and one from the Asus router). I did this setup because I couldn't get AP mode working and still have LAN connections to the Asus (only wifi would work in AP mode for some reason.. but in routing mode I can have both).

My new setup is as follows:

  1. Rogers Hitron Model/Router combo to the wall via cable (coaxial) configured with Gateway functions on as well.
  2. Asus AC-RT88U's WAN port to Rogers Model/Router combo's LAN port (just like Bell).

Double NAT:

But then I ran into the infamous Double-NAT problem. I realized Rogers doesn't use PPPOE and therefore doesn't have a "username" and "password" to get a direct WAN IP like with Bell..

Proposed Resolution:

So I decided to log into the Rogers modem/router combo and do the following:

  1. Create a DHCP-Reservation for the Asus Router on 192.168.2.10
  2. Assign DMZ to 192.168.2.10

Failure:

However, the Asus router is still showing that it has a PRIVATE WAN of 192.168.2.10 :(

How can I get it to connect to the internet directly?! I've been trying for hours but for some reason it still shows as private.

Pics (Asus configuration for Rogers):

enter image description here enter image description here

Configuration for Rogers Modem/Router combo: enter image description here

Any ideas why the Asus router is NOT getting the public IP and is being put behind NAT?

5
  • DMZ doesn't "swap roles" between the router and the selected device/host. AFAIK, on many (if not most/all), DMZ pretty much means "port forward everything", without even isolating the selected host from others. – Tom Yan Sep 30 '19 at 23:56
  • only wifi would work in AP mode for some reason If it can be switched to "AP mode", which I assume would switch off its own DHCP server and so, perhaps you should connect "LAN-to-LAN" instead of "WAN-to-LAN". – Tom Yan Sep 30 '19 at 23:59
  • 1
    Call Rogers, ask them the put their modem in Bridged Mode and then connect a router to it via the WAN interface on the router. This will give you the external IP address on your router. I have Rogers here and this is how I do it. – John Oct 1 '19 at 0:02
  • @TomYan I solved it. Holy crap.. So the weird part was.. I kept it connected via WAN to WAN and wifi worked in AP mode.. but not LAN ports.. so then I changed the IP of the Asus Router to something insane and not even close to the Model/Router combo.. now all of a sudden both Wifi and LAN ports work on the ASUS in AP Mode.. :l Typically NOTHING would work.. I did not expect this. – Brandon Oct 1 '19 at 0:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.