1

Edit: My home network is behind a CG-NAT. Figured that out when I saw my WAN IP in my router settings was different than my public IP as shown at ip4.me. I'm not sure what my options are at this point.


I've been researching this problem for weeks now. I'm a novice when it comes to networking. So this issue could be insanely simple to resolve.

This seems to be the closest search result to my issue. But I will outline what I've done below.

I have a home PC running Windows 10 Home (not Pro) connected to a home network and Internet via an ASUS RT-AC68U router. I have installed OpenSSH Server and have confirmed it is running via PowerShell:

Get-Service -Name *ssh* | select DisplayName, Status, StartType

I've also confirmed that the Firewall rule is active to allow connections to port 22, again via PowerShell:

Get-NetFirewallRule -Name *SSH* | select DisplayName, Direction, Action, Profile

  • OpenSSH Server (SSHD)
  • Direction: Inbound
  • Action: Allow
  • Profile: Any

(Not sure if this is the correct way of confirming. But I've also checked in the list of Inbound Rules in the Firewall settings. OpenSSH Server, Port 22 rule is active.)

I've enabled port forwarding in my router as well based on the instructions (pg 69):

  • WAN>Virtual Server/Port Forwarding>Enable Port Forwarding: True
  • External Port: 22 (not sure if that's correct)
  • Internal Port: 22 (again, not sure)
  • Internal IP Address: server IP address on network

On the client side, I set up the connection as [pc username]@[WAN IP] and port: 22 based on the linked router instructions. However, I am getting timeout errors or 'Socket is not connected' errors whenever I try to connect with the client connected to an external network (using Shelly on iOS 13 on cellular LTE network).

Your help would be greatly appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.