0

I am using XFCE and when I clicked on Terminal Emulator its ask you to put what program to execute. I wrote "terminal" and now it shows this message:

"Failed to execute child process "terminal" (no such file or directory).

I know that I incorrectly typed "terminal" but I don't know how to fix it.

Alpine Linux running on VirtualBox

  • May you please provide screen shots of the messages you are seeing in your question? – Gordster Oct 1 '19 at 18:21
  • What if you type "bash" – Gordster Oct 1 '19 at 18:44
  • That's the problem. Where would I type "bash" if I cannot open Terminal? – Rodrigo Camargos Oct 1 '19 at 18:47
  • In the question you mention typing the word "terminal". I meant to type it in that location. Can you use the gui to figure out where the terminal program is installed? Mine is at /usr/bin/x-terminal-emulator and another is at/usr/bin/gnome-terminal. You most likely have to specify the full path – Gordster Oct 1 '19 at 18:55
0

You would have to specify what to run when you click on Terminal Emulator. This would be the shell, most likely /usr/bin/x-session-terminal. Type that or use /usr/bin/gnome-terminal rather than using the actual keyword "Terminal" as there is no program that actually is named terminal to execute; "Terminal" is the icon name. The easiest way to find installed terminals is to look for them in your file viewer (Thunar) or to switch to a tty (Ctrl-Alt-F#) and use the whereis command.

|improve this answer|||||
0
  1. Press Ctrl+Alt+F2 to get to the second console
  2. Login & password
  3. apk add xfce4-terminal, reboot
  4. Applications > Settings > Preferred Applications > Utilities

    And set Terminal Emulator to XFCE Terminal.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.