I have a proprietary piece of hardware powered by USB. Plugging in this hardware on an older laptop from somewhere between 2005 and 2010 works just fine. Plugging this power into my newer laptop (2017 T470) does NOT power on the device. I have tried using a USB hub with additional power but that still does not work.

Can anyone explain why this is happening?


  • 1
    What's the device? Oct 2, 2019 at 15:52
  • 2
    Does the newer laptop charge other devices? Also, what system are you running? There are settings about the port that can be managed from the operating system. Oct 2, 2019 at 16:02
  • 1
    The issue likely arises from the USB drivers on the older device, and is a common problem with devices circa <=2012/2013, which is why board manufacturers still add USB2 ports to mother/server boards. A great example of this is an old Droid RZR Maxx I have that will not allows file transfers on a laptop with only USB3 ports... I have to use an older laptop which has USB2 ports. I'm not sure of the technical reasons behind this incompatibility, but it is widespread enough someone should have written about it somewhere (I'd try researching on Google).
    – JW0914
    Oct 2, 2019 at 16:50
  • 1
    @wrecclesham The device is essentially a board with several relays on it, with an rs232 out and a (house-shaped) USB in. The board is powered via the same USB.
    – Chris
    Oct 2, 2019 at 18:07
  • 1
    @EduardoTrápani The newer laptop DOES charge devices, but it takes roughyl 6 - 8 hours to charge my galaxy S8.
    – Chris
    Oct 2, 2019 at 18:08

1 Answer 1


My similar experiences

On one of my Windows PCs (a powerful new Intel Skull NUC), there are several USB ports. Three of these ports are the newer USB3 (blue inside) and the remainder are the older USB2 (white).

For reasons I don't technically understand, a few of my very old devices (e.g. a very old mouse), which work perfectly on old Windows PCs, will not connect at all when plugged into the USB3 ports of my new Skull but will connect perfectly on the USB2 ports.

Also, I have other very old devices (e.g. a portable Brother scanner) that will not connect to the new Windows PC unless I use a very specific USB cable (which happens to be a white USB cable that normally connects my Arlo camera to its power supply).

My suggestions for you

I don't understand the technical reasons for these incompatabilities, but the practical suggestions I offer are:

  1. try plugging your old devices into the different USB ports on the PC, in case the USB2 and USB3 ports have different compatabiities with your old devices; and

  2. try using a varient of different USB cables to connect the old device to the new Windows PC.

Good luck!

  • I have tried all the USB ports and 2 separate cables :(. I am thinking maybe getting a newer powered USB adapter with an actual DC adapter instead of a microUSB power.
    – Chris
    Oct 2, 2019 at 18:09
  • Let us know if the newer USB adapter works, as there may be lessons for those that follow. As @JW0914 notes, the problem is sufficiently widespread for an answer to be worthwhile.
    – TechnoCat
    Oct 2, 2019 at 22:17

Not the answer you're looking for? Browse other questions tagged .