I'm an unlucky owner of and Acer 7720G laptop which, like many in its category, has receiver for a proprietary infrared remote control device (which I did not receive with my laptop!) .

Now my problem is that the receiver is detected as Microsoft eHome MCIR Keyboard, Microsoft eHome MCIR 109 Keyboard and Microsoft eHome Remote Control Keyboard keys.

My problem is that this driver has incompatibilities with some programs I use like for example DosBox. When these devices are installed, they cause DosBox to incorrectly detect some keyboard buttons. The workaround is to remove or disable the 3 hardware devices. Unfortunately, I the disable option is grayed out and when I delete them, they are reinstalled on next restart. Is there any way to hack windows in order to prevent their installation? I was thinking about locating the drivers these devices use, but they are buried somewhere in windows installation and I don't have enough experience to find them, so I'm asking you for help.

EDIT: Using 64 bit version of windows.

4 Answers 4


I had a similar issue and kludge fixed it the following way:

  1. Download DevCon
  2. Copy the correct version of DevCon into windows directory (optional)
  3. Create a batch file containing the following: devcon remove circlass\irdevicev2
  4. Copy the batch file to your startup folder - you may need to right-click the actual devcon file and set compatability mode to always run as administrator

*the above could be a security risk - if in doubt, copy devcon and the batch file to a folder not in the path

  • 1
    oh, and if the device isn't called circlass\irdevicev2 then go into device manager, select the eHome device, properties, then on the details tab change the dropdown to show Hardware Ids and use the value shown! Jun 6, 2010 at 13:21
  • Seems to be close, but program says C:\devcon\i386>devcon remove circlass\irdevicev2 CIRCLASS\IRDEVICEV2\1&79F5D87&0&PORT1 : Remove failed No devices removed. Also, I have amd64 version of windows and this appears to be available only for i386 and IA64. Newer version of devcon seems to e available in windows driver kit. I'm going to get 7.1.0 and try with that version.
    – AndrejaKo
    Jun 6, 2010 at 13:44
  • I was right. windows driver kit 7.1.0 does contain amd64 version of DevCon and it seems to be working. Thanks!
    – AndrejaKo
    Jun 6, 2010 at 13:52
  • Great, I never saw Windows-7 in the tags (doh!) Jun 6, 2010 at 16:00

Have you tried looking in the BIOS settings for a switch to disable the hardware? If you can disable it, then you should be able to remove the device drivers permanently.

  • Unfortunately, I have Insyde H2O UEFI on my laptop. Like many other laptops that use that particular piece of software, all access to UEFI is disabled and in emulated BIOS there are no useful options. I even had to modify UEFI image in order to enable Intel VT-x. I strongly recommend avoiding computers which use H2O!
    – AndrejaKo
    Jun 6, 2010 at 18:41

Guys from notebookreview.com forums recommended that I try with system->advanced system settings->hardware->device installation settings and disable downloading drivers from windows update. Unfortunately, this does not help me. Also it may be significant that there is no new hardware detected dialog. Drivers are already installed once system starts.


I believe I found an answer. Instead of trying to keep it uninstalled I decided replace the driver.

WARNING: This will disable your Remote Control!

  1. COPY don't move, just COPY "C:\windows\system32\drivers\kbdclass.sys" to your desktop

  2. Rename the "kbdclass.sys" on your desktop to "kbdhid.sys"

  3. take control and delete(i always back things up into a different folder) "C:\windows\system32\drivers\kbdhid.sys"

  4. Move the "kbdhid.sys" from your desktop to "C:\windows\system32\drivers"

  5. Now when you restart it installs the basic keyboard drivers into you HID keyboard divers. so the drivers will still show in your device manager, but will work as the stander driver. (PS. if you have a remote control for your PC, doing this will probably make it never work.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .