I have this weird problem that almost every .NET application crashes, including .NET Core 3.0. (2.2 runs fine)

Noticed this first with Visual Studio Installer and Visual Studio. ServiceHub is almost constantly crashing. Several error logs are being reported in the event viewer about .NET Runtime.

In some cases, there is no problem and the application runs without error or crash. But most of the time, it crashes. Other applications run just fine and don’t show this behaviour.

I’ve collected a lot of logs and uploaded them into a folder here. Almost every error is a AccessViolationException.

Most of the times, the faulting module is clr.dll, as can be seen here:

Faulting application name: Microsoft.ServiceHub.Controller.exe, version:, time stamp: 0x9af4007e
Faulting module name: clr.dll, version: 4.8.4018.0, teitstempel: 0x5d4a67fe
Exception code: 0xc0000005
Fault offset: 0x0000000000001fce
Faulting process id: 0x2c38
Faulting application start time: 0x01d57aca1289ebe9
Faulting application path: C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\ServiceHub\Controller\Microsoft.ServiceHub.Controller.exe
Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll
Report Id: e4529198-7beb-4ebe-a8c7-30cf8ba83917

But in other occasions, the module is just empty or a other file, such as KERNELBASE.dll.

I tested my memory with the windows memory diagnostic tool and memtest86 (the standard free test). No errors were found. Checked the timings of the RAM in my BIOS and everything is correct. The XMP 2.0 profile is active.

I also tested this on a Windows 10 VM by installing a clean build on VMware Workstation and installing nothing else than Firefox and Visual Studio Installer, but the problem also seems to occur there.

.NET Core 3.0 adapts the same behaviour. In most of the cases, I can’t create a project for example. It crashes randomly, whereas the .NET Core 2.2 SDK runs just fine.

Going into safe mode and trying to run these applications there does not fix it. Tried it with the default safe mode and the safe mode with network drivers.

This problem is not only persistent on Windows, but also on Ubuntu. I tried creating and running a .NET core 3.0 projet on a Ubuntu 19.09 live usb and in approximately 20 runs, the application crashed like 3-5 times with the same error.

I’m currently on a fresh install of Windows 10 (1903) on a i9 9900K and the latest updates are installed. Every driver is up to date, including the BIOS.

My graphics card is the RTX 2080 and Windows 10 is installed on a 970 EVO Pro.

  • 1
    If you uninstall .NET Core and only have .NET 4.8 installed are you able to run applications targeting that version?
    – Ramhound
    Oct 4, 2019 at 16:33
  • @Ramhound Sadly, no.
    – Aarivex
    Oct 6, 2019 at 22:29
  • Did you understand what I was asking you to verify? Are you saying any .NET application when launched generates an error in the event log? Seems odd this behavior would extend to Linux. I had a similar error a few weeks ago, but it was only a specific .NET 4.6.1 application, and when I upgraded to 1903 the problem was resolved.
    – Ramhound
    Oct 6, 2019 at 22:43
  • I did understand your question and I can indeed verify, because in one side, .NET applications were crashing right after a fresh installation of windows, and at the other side, I tried playing around uninstalling and installation several .NET framework/core stuff and it didn't fix anything. Nevertheless I forwarded this to Intel with my current processor warranty and let's see.
    – Aarivex
    Oct 7, 2019 at 17:14
  • The .NET Framework 4.8 cannot be removed since you are running Windows 10 version 1903. Since .NET Framework 4.8 is a direct replacement for all other versions, this means that .NET Framework cannot be removed, only the .NET Framework Targeting Packs can be removed and .NET Core. So were you trying to install .NET Core or .NET Framework 4.8?
    – Ramhound
    Oct 7, 2019 at 17:25

1 Answer 1


This problem got solved. My CPU had a problem, causing to the error above. Sent it back, got a new one and it works fine now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .