17

Android Studio requires Hyper-V, but installing Hyper-V also enabled VBS (Virtualization-based Security). The problem is AMD's Ryzen software doesn't run if VBS is enabled.

enter image description here

Applying the following script gave me an option to "opt-out" from VBS on the next reboot, but that does not seem to be permanent. Restarting Windows seems to enable VBS again. So, it seems that I have to run the script and press the opt-out key every time.

Is there anyway to disable VBS permanently and never ask me to disable it again?

set FREE_MOUNT_VOL_DRIVELETTER=L:
mountvol %FREE_MOUNT_VOL_DRIVELETTER% /s
copy C:\WINDOWS\System32\SecConfig.efi L:\EFI\Microsoft\Boot\SecConfig.efi /Y
bcdedit /create {0cb3b571-2f2e-4343-a879-d86a476d7215} /d "DG" /application osloader
bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} path "\EFI\Microsoft\Boot\SecConfig.efi"
bcdedit /set {bootmgr} bootsequence {0cb3b571-2f2e-4343-a879-d86a476d7215}
bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} loadoptions DISABLE-LSA-ISO,DISABLE-VBS
bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} device partition=%FREE_MOUNT_VOL_DRIVELETTER%
mountvol %FREE_MOUNT_VOL_DRIVELETTER% /d

Local Group Policy does not seem to work. enter image description here


The Registry value EnableVirtualizationBasedSecurity already has been set to 0.

enter image description here

5
  • Is this system connected to an Active Directory domain?
    – Ramhound
    Oct 4, 2019 at 18:09
  • No, it is not joined to a domain. Oct 4, 2019 at 18:14
  • did you ever find a solution? Nov 13, 2019 at 18:38
  • figured it out. virtualization based security isn't a registry or bios setting. It's the same as setting bcd with bcdedit hypervisorlaunchtype off that I've been doing for years for hyper-v vmware dual boot. hanselman.com/blog/… Nov 13, 2019 at 19:27
  • 1
    Is there any new and working solution
    – m123
    Oct 18, 2020 at 13:36

8 Answers 8

3

"HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\DeviceGuard and add a new DWORD value named EnableVirtualizationBasedSecurity and set its value to 0 " DID the trick for me.

1
  • 2
    Explaining what this does would make it a better answer. Please use the EDIT button to improve your post. Apr 13, 2020 at 5:19
1

This procedure should disable Virtualization Based Security:

  • Run gpedit.msc
  • Go to Local Computer Policy > Computer Configuration > Administrative Templates > System > Device Guard
  • Double click Turn on Virtualization Based Security
  • Select Disabled
  • Click OK
  • A reboot might be required.
9
  • 3
    It already has been set to "Disabled". Oct 4, 2019 at 17:13
  • Then how come it is not disabled? Please run System Information to verify if this is the case (it is found very low in the list).
    – harrymc
    Oct 4, 2019 at 17:36
  • 1
    I have added the screenshot to the end of the question. It seems that Windows ignores that setting and re-enables VBS every time (except when I ran the script). Oct 4, 2019 at 18:03
  • 1
    That value already exists and has been set to 0. I think I probably had tried some script on the Internet to try to disable VBS, and that might have done that. I'll add the screenshot to the end of my question. Oct 4, 2019 at 19:41
  • 1
    On a Win10 2004 (post 2004 update) I found that, with all the above things disabled, group policied to disabled and relevant registry entries present, I STILL had to issue bcdedit /set hypervisorlaunchtype off at an admin PowerShell then reboot in order to get VMWare Player to fire up a VM. I compared what I'd already done with the guide at windowsreport.com/disable-credential-guard-windows-10 and other responses to this question. Oct 5, 2020 at 23:12
1

As far as I understand: Either it can't be disabled unless disabling Hyper-V, or Ryzen Master is treating Hyper-V same way as VBS.

Any way OP was asking this question because he wanted to execute Ryzen Master (as well as I was today).

Heare I would print hacky solution to launch Ryzen Master without disabling Hyper-V.

Reddit user klauspost has created a patch that allows bypassing this checks in Ryzen Master. I've tested and it works on my machine and it indeed able to change CPU configuration.

The patch itself: https://github.com/klauspost/ryzen-master-vbs-patch Reddit thread: https://www.reddit.com/r/Amd/comments/gtvy2w/patch_for_amd_ryzen_master_to_work_with/

Some youtube video with tutorial how to apply patch: https://www.youtube.com/watch?v=h7xId0RO9Rk

P.S. As far as I understand: AMD don't want to cause any stability issues so they won't officially allow ti run with Hyper-V. It can cause some issues with virtualization. Hyper-V is such type of VM that is running at top of Windows, so your OS is always run inside VM.

So use this patch for your own risk. Neither I nor patch author is responsible for possible damage.

0

I did all the same things you did (GPedit, RegEdit).

Finally, disabling secure boot and any VBS option in the BIOS did the trick.

1
  • 8
    What do you mean "VBS option in the BIOS"? You mean, virtualisation feature such as AMD-V or Intel VT-X? If so, that has the same effect as disabling Hyper-V. I need to use Hyper-V. Oct 30, 2019 at 22:34
0

I have 20.04 installed and what I found is that other than what @dyasta had mentioned above, be sure to unselect the Windows Features of Windows Defender Application Guard.

In my case, I managed to turn VBS off by making the GPEDIT change suggested above, turned off all Hyper-V features, turned off Windows Defender Application Guard, and reboot.

1
  • Turning Hyper-V off is not an option :( Aug 22, 2021 at 11:51
0

I had the same error as you. What I did was turn off the below features in Windows features.

  • Windows Hypervisor Platform
  • Virtual Machine Platform
  • Microsoft Defender Application Guard

The reason: there are multiple System Components that utilize VBS.

0

If this is an option for you, update to a newer version of Ryzen Master and have Hyper-V turned on and VBS running, without making other changes. It appears that newer version(s) of Ryzen Master allow VBS to be running. But specifically which versions do or do not, I'm not sure.

I am using Windows 10 Pro version 1909 and Ryzen Master version 2.8.0.1937, with Hyper-V turned on and VBS running.

System information via Ryzen Master and Windows

2
  • Would you please care to explain why you downvoted this?
    – Tarocco
    Mar 19, 2022 at 8:00
  • I would vote up to ballance things. Ps. Nice to know. Need to try new version. May 8, 2022 at 0:29
-2
  1. Make sure you've removed Windows Features that may use Hyper-V. Including, Hyper-V, Windows Subsystem for Linux, Sandbox, etc...
  2. Modify boot configuration to disable Hypervisor services:

    bcdedit /set hypervisorlaunchtype off

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .