5

I have a new, OEM installation of Windows 10 that is unable to contact any time servers to sync the system time. Each attempt gives me a timeout error, and pinging the time server times out as well. Here is what I've tried:

  • Checked that the Windows Time service is running and set to automatic startup, and restarted it
  • Disabled my firewall
  • Tried using time.nist.gov, which is currently working according to NIST
  • These steps using w32time, which appeared to succeed but didn't update the time

The time is currently off by 7 hours, which shouldn't be far enough to break Internet syncing.

EDIT: Just tried the same steps on my other computer which boots only Windows (albeit an longer-standing installation of 10), and had the exact same issue, except when I try syncing it simply says "An error occurred when Windows was synchronizing with time.nist.gov." So I highly doubt it is dual boot-related. What is going on?

5
  • Possible duplicate of Windows vs Linux Local Time? – Ramhound Oct 6 '19 at 20:44
  • No; I just updated my most explaining I reproduced it on a Windows 10-only machine. – David Pitchford Oct 6 '19 at 22:23
  • 1
    Impossible to say without seeing a specific error. What does the System Event Log say? Find any messages with Source = "Time-Service". – ivan_pozdeev Oct 7 '19 at 3:51
  • 1
    Have you tried threatening the computer with pliers and a sledgehammer? – Vikki - formerly Sean Oct 7 '19 at 4:08
  • Having the same issue on my new Windows 10-only machine that has never been dualbooted. – Alexander Revo Oct 7 '19 at 5:16
6

The issue of the 7-hour difference is caused by dual booting between Windows, which by default uses your local time zone (perhaps US Mountain Time or Krasnoyarsk Time Zone), presumably 7 hours from Coordinated Universal Time (UTC), AKA "GMT", and Linux, which by default uses the single UTC time zone. This is further complicated where Daylight Saving Time applies.

Decide which you prefer, UTC or local, and change the other OS to respect that time.

  • To adopt UTC across the board:
    • In Windows, press Windows, type time zone, and select Change the time zone.
    • Select the Coordinated Universal Time (UTC) time zone.
  • To adopt local time in both systems:
    • In Mint, set the time to your local time and time zone from the control panel.
    • Press CtrlAltT to open Terminal.
    • Type timedatectl set-local-rtc 1 --adjust-system-clock and press Enter.

The issue that time.nist.gov fails to synchronize time might be due to timeserver or network latency. The Windows Club has a nice tutorial on setting the time server and adding other servers through the Registry, which are REG_SZ values at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DateTime\Servers.

Set Windows time server

On my PC, about three-quarters of attempts to sync to time.nist.org failed with, "the timeout period expired." However, after adding pool.ntp.org and selecting it, synchronization succeeded consistently. Perhaps NIST is overloaded?

8
  • Setting Windows time to UTC makes it off by exactly 12 hours (4:30 AM instead of PM), and the Linux time becomes wrong as well, until it auto-syncs up again. I tried setting local RTC in Linux and it appeared to work there (the time stayed correct), but the Windows time (with the time zone set to my local TZ) is still incorrect. Like I said, my big problem isn't the time difference between Windows and Linux, it's Windows' inability to sync with a time server. – David Pitchford Oct 6 '19 at 21:39
  • There are tips on fixing Window time sync issues at windowsreport.com/fix-windows-10-clock and at thewindowsclub.com/windows-10-clock-time-wrong-fix , but you've tried many of these. One other idea: recent Windows 10 updates could be problematic; try rolling back. – DrMoishe Pippik Oct 6 '19 at 22:31
  • 1
    Changing Windows time zone will indeed break daylight saving time, I wouldn't recommend to do it - that's not what this setting is intended for. There are registry tweaks that would switch Windows to UTC system clock, but they are silently reverted on certain occasions. Changing Linux settings is the only reliable solution. – gronostaj Oct 7 '19 at 4:29
  • 1
    You can also set Windows to read/write the hardware clock as UTC: superuser.com/questions/975717/… . It requires disabling time sync, a registry change, a reboot, and then re-enabling time sync, because the registry key is only read at boot time. – Simon Richter Oct 7 '19 at 9:26
  • I tried this and the clocks on Windows and Linux are now in sync, but I am still unable to sync the time with time.nist.gov. – David Pitchford Oct 14 '19 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.