7

This bothers me for ages, and I could not find the solution yet.

  1. Open Windows Explorer.
  2. Click on Desktop in the left sidebar.
  3. Click on "Desktop" in the address bar.

Result: Instead of C:\...\ it displays only Desktop.

Desktop Windows Explorer

Instead I would like to get the real physical path:

C:\Users\MyName\Desktop\

How to achieve this (settings in the Windows registry)?

6
  • One simple answer is to add it under Quick access.
    – AFH
    Oct 7 '19 at 10:33
  • 1. I am not using Quick access. 2. It is still the same, the path does not show up.
    – Avatar
    Oct 7 '19 at 10:45
  • This probably isn't quite the answer you are looking for, but if you go to C:\Users\<yourUser>\Desktop, it does put the full path up in the address bar. More clicks, but it does give you the full path technically. I know your pain however - I can't count how many times I've clicked the "Desktop" option and tried getting the path in the address bar for a quick copy and paste...
    – Tim G.
    Oct 7 '19 at 11:33
  • 2
    Logical path will always be %UserProfile%\Desktop
    – JW0914
    Oct 7 '19 at 11:42
  • 1
    For the Desktop specifically, I think it's related to the ParsingName value under: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{754AC886-DF64-4CBA-86B5-F7FBF4FBCEF5} Oct 7 '19 at 11:46
4

It's not possible to change this particular aspect of Windows' behaviour from the GUI but there is a nice workaround that doesn't require any third-party software:

  1. Open Windows Explorer: Windows+E.
  2. While holding Shift, perform a Right click 🖱️ on the Desktop folder, then choose Copy as path from the context menu:

enter image description here

The full path of your Desktop folder is now copied to the clipboard and can be pasted into the address bar or wherever you require it.

Note that the path will include quotation marks that you'll need to remove in order for it to work properly in Windows Explorer.

This should give you something like this:

"C:\Users\Kai\Desktop"

6
  • In Windows 10, I don't see the Copy as path in the Context menu.
    – user8356
    Oct 7 '19 at 17:37
  • You will if you hold Shift while you perform the right mouse click. I think I need to rephrase my answer! Oct 7 '19 at 17:38
  • 1
    No really, I was holding down Shift, and right-clicking the desktop -- but I the problem is, I was looking at a Favorites view in Explorer, not the Computer view. When I changed to that, I did have the "Copy as path" command. Good tip!
    – user8356
    Oct 7 '19 at 17:46
  • It's a nice little shortcut. Useful for other things too, like when you need file paths for scripting. Most people don't even know it exists! 😄 Oct 7 '19 at 17:58
  • Removing the question marks takes too much time. My workaround that I used until today (faster than your suggestion, I think): Open Desktop, open a folder, go to address bar, et voila: The path. – But as in the question, I want to click in the address bar and get the full path. One click and done :)
    – Avatar
    Oct 8 '19 at 5:30
2

Using %UserProfile%\Desktop reveals the Desktop path.

So I solved it with this Autohotkey script:

; Save Dialog: hitting CTRL D opens desktop
^d::
    ControlFocus, DirectUIHWND2, A
    SendInput, % "!d%userprofile%\Desktop{enter}!n"
return

OR:

; Windows explorer, hitting CTRL D goes to address bar and shows the full desktop path
#IfWinActive ahk_class CabinetWClass
    ^D::
        Send !D
        String := "%UserProfile%\Desktop"
        SendRaw %String%
        Send {ENTER}
        Send !D
    return
#IfWinActive

Hitting CTRL D does focus the address bar now and reveals the path:

AHK Ctrl D path in address bar

Finally one Windows problem less 👍

0

It's hard to battle the Shell namespace. As a workaround, the following .reg file will add a context menu item to open the file system folder corresponding to a shell folder.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\Background\shell\OpenFSFolder]
@="Open file folder (new window)"

[HKEY_CLASSES_ROOT\Directory\Background\shell\OpenFSFolder\command]
@="explorer.exe \"%V\""

[HKEY_CLASSES_ROOT\Directory\shell\OpenFSFolder]
@="Open file folder (new window)"

[HKEY_CLASSES_ROOT\Directory\shell\OpenFSFolder\command]
@="explorer.exe \"%V\""

0

You can use right click-property on folder name, copy parent path then add the name of folder you want to access.

example

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.