I have a problem with the Windows 10 search where it keeps showing old programs after I've uninstalled them. One example is Apple Software Update:


And when I click or right click on it, nothing happens. I want to note that this is not the only program that it keeps showing.

I have uninstalled it, removed it from the start menu, removed it from the registry, removed all Apple folders I could find anywhere yet it's still there.

I've tried rebuilding the search index, I've even deleted the Windows.edb file in C:\ProgramData\Microsoft\Search\Data\Applications\Windows

I've ran SFC scannow, startcomponentcleanup and restorehealth in DISM and they had stuff to repair but now say that everything is fine.

I tried taking ownership of the C:\ProgramData\Microsoft\Search\Data folder, and now I got some weird issues where when I scan for problems in the windows diagnostics, it says incorrect permissions for the windows search directories:


And then after I ran it the permissions change in the data-folder to the following:


No matter what I do I still get "incorrect permissions for the windows search directories" and the problem remains.

Thank you!

  • I believe the problem is that these programs still show up regardless of the index, so there might be some Start Menu folder or cache that hasn't cleared - but I wouldn't know what that would be Oct 7, 2019 at 15:03
  • This solution (from a different question) worked for me.
    – nevermind
    Nov 29, 2021 at 16:04

3 Answers 3


This is a little late, but I had a very similar problem recently that I was able to resolve using this solution

Go to C:\Users\User\AppData\Local\Packages\

Delete the folder \Microsoft.Windows.Cortana_cw5n1h2txyewy

If you cannot delete the folder, enter into the folder and delete as many as the sub folders as your system permits.

I restarted Cortana from Task Manager, but the original link mentions logging out and back in again which might be worth trying.

This cleared out my old Visual Studio 2017 and Powershell 7 (Preview) search results. It also fixed the issue I was having setting a custom -WorkingDirectory path in the Powershell shortcut which would cause Search to hang for 15 seconds and fail to open

  • Is there any way to fix this permanently? Your workaround worked for me, (although the folder was called Microsoft.Windows.Search_cw5n1h2txyewy on my system), but now every time I uninstall or install a program and want to update search, I have to delete that folder. Aug 13, 2021 at 19:22
  • 1
    I found that the deleting the subfolder of C:\Users\"User"\AppData\Local\Packages\Microsoft.Windows.Search_xxxxxx work for me.
    – Tawei
    Sep 10, 2021 at 22:05

I had been trying to find a solution for almost a year after countless hours of research, index rebuilds and resets, Windows search troubleshooting, looking through Start Menu items, reinstalling apps, removing shortcuts to no avail. I finally got it resolved by doing as Tawei mentioned above:

I found that the deleting the subfolder of C:\Users"User"\AppData\Local\Packages\Microsoft.Windows.Search_xxxxxx work for me.

I suggest Microsoft improve the Search and Indexing troubleshooter by automatically removing the "Microsoft.Windows.Search*" directory, it would be helpful for completely resetting the Windows Search feature and resolving these issues.


Windows Search is broken on a few systems for a few months already. Unfortunately I didn't find another workaround than installing classic shell which is using a custom search implementation compared to the Windows 10 1903 default search (it still relies on the windows vista/7 indexer).


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .