2

Host: Windows 10
Guest: 2x Ubuntu 16.04
VM: Virtualbox
Networking: host-only adapter

I cannot use bridged mode because my company's network won't assign an IP address to the VMs.

I set up Samba on Ubuntu-VM-1 and I'm able to access the Samba share from Ubuntu-VM-2.

However, from Windows I cannot access the Samba share.

Status:
* Ping between all guests and host
* Mount samba share of Ubuntu-VM-1 in Ubuntu-VM-2
* I can see Ubuntu-VM-1 from Windows: \192.168.56.101 but the share doesn't show up

In Windows Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings I've set all the settings to the most permissive modes.

7
  • Have you tried typing in the Samba server's IP in Explorer to access the share (\\192.168.1.2\share\name)? Windows 10 will not show Samba servers in Explorer unless you've correctly configured static DNS entries within the host file and DNS server, coupled w/ setting the same local domain/workgroup name, or have mapped the share. Have you verified what SMB version the Samba server is using? Try setting minimum and maximum values to SMB2 within smb.conf (note: SMB1 should not be utilized). Have you reviewed the Samba logs to determine if any errors are being generated?
    – JW0914
    Oct 8 '19 at 16:15
  • Yes I'm using the actually IP. The problem is a Windows problem: I can access the share from the other Ubuntu-VM.
    – Bob
    Oct 8 '19 at 16:20
  • @JW0914 you've typed a lot of conditions so let's take one at a time. Version is Version 4.3.11-Ubuntu
    – Bob
    Oct 8 '19 at 16:23
  • @JW0914 I set the min and max protocol to SMB2 but still doesn't work.
    – Bob
    Oct 8 '19 at 16:30
  • More likely than not, the issue resides within the smb.conf options set and/or a DNS/networking issue. This requires troubleshooting that's more beneficial on a forum and is where I personally would recommend going for troubleshooting. Logs and the smb.conf are likely going to be required to post, and currently, this is way too open-ended to efficiently troubleshoot here.
    – JW0914
    Oct 8 '19 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.