I keep getting this irritating warning when copying files over the network:

These files might be harmful to your computer

These files might be harmful to your computer

Your internet security settings suggest that one or more files may be harmful. Do you want to use it anyway?

I am copying a file from \\192.168.0.197\c$ (home server) to my local machine which is at \\192.168.0.4.

How do I turn off this meaningless "warning"?

10 Answers 10

up vote 156 down vote accepted

I found a fix by changing "internet options" -- so I guess Windows is detecting the "internet" as my own network.. sigh.

  • Click Start / Control Panel / Internet Options
  • Click Security tab.
  • Click Local Intranet
  • Click Sites button.
  • Click Advanced button.
  • Enter the IP Address of the other machine or server (wildcards are allowed) and click Add
  • Click Close, then OK, then OK again.
  • Disconnect, and reconnect the network drive

Changing Internet Options screenshot

This worked for me, but it's a bummer I have to manually enter IPs here.. it would be nice if Windows could detect this is a local network file copy and skip the irritating (and pointless) warning about "dangerous" files.

Sidenotes:

  • If you are using a DNS name to map the network drive, adding the IP address of the server to the zone will not work. You will need to add the DNS name, and vica-versa.
  • When adding an IP address, you can use wildcards like so: 192.168.1.*
  • Whan adding a DNS name, you can use wildcards like so: *.example.com
  • 2
    note @gerbenny answer at the bottom about wildcards in the sites dialog. – IgalSt Aug 1 '11 at 9:04
  • 8
    Note that if the network share is open while this change is made, it has to be closed and reopened to see the change. – azdev Sep 25 '12 at 13:14
  • 3
    Didn't work here; still get the warning. – gravitation Apr 21 '13 at 23:22
  • 4
    This also increased copy from network speed by 50% !! (through wifi) – Odys Oct 29 '14 at 14:26
  • 1
    It seems to have worked with the 10.0.0.0/24 format too. – Nulano Mar 22 '17 at 18:36

Using Windows 7, I added my IP address with a wildcard:

10.55.25.*

Now all the ip's in this range are part of the "Local Intranet".

  • 21
    ah, good tip, it is not clear that dialog supports wildcards. – Jeff Atwood Apr 23 '11 at 10:56
  • Can you explain what you add this IP address to? – Charlie Harding Sep 16 '16 at 15:48
  • 1
    @CharlieHarding: This answer was an addition to Jeff's answer of June 5 2010. So, you'd add this to the Local intranet zone dialog box. – Wouter Feb 23 '17 at 9:22
  • It tells me I have entered an invalid wildcard sequence when I try to add *.local. – mm201 Aug 24 at 4:30

If you want to do this in Group Policy, this quote may be helpful to you.

You can control this with Group Policy, as well. Use gpedit.msc and drill down to

User Configuration → Policies → Administrative Templates → Windows Components → Internet Explorer → Internet Control Panel → Security Page

Enable "Intranet Zone Template" with the Low option.

Then enable "Site to Zone Assignment List" and use the Show button to add your "sites" (servername, servername.domain, ipaddress - the values you enter depend on what name or IP you use to access the share) with a value of 1.

Lastly - and this is the most important step - drill down one folder in gpedit to "Intranet Zone" and enable for "Show security warning for potentially unsafe files", choosing Enable from the drop-down.

Close gpedit, reboot or run gpupdate /force and enjoy no more annoying Windows Security dialogues!

From the bottom of http://social.technet.microsoft.com/Forums/fi-FI/w7itprosecurity/thread/35ca8f9c-5e69-4b7f-a002-0d72fa0dc14b

  • 4
    This is the best way! – Jeffrey Kevin Pry May 8 '13 at 16:19
  • 1
    For anyone else following this, I couldn't find the .../Intranet Zone/Launching programs and unsafe files setting in my policies. However just doing the first step with file://*.example.com=1 did the trick. – Styne666 Jun 28 '14 at 10:30
  • 4
    The last setting seems to now be called "Show security warning for potentially unsafe files" and needs to be Enabled with the option set to Enable. – thaimin Jan 3 '16 at 5:17

We recently put in a new server using DFS and I was having this same error. I ended up putting in:

" \\\servername.local.?"

After clicking add, it then showed:

file://*.servername.local.

I tried the * verses the ?, but that was not allowed.

I did a procmon and found where the settings are stored in the registry - this is for my 192.168.1.* network:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Ranges\Range1]
"*"=dword:00000001
":Range"="192.168.1.*"

This is for my \\NAS server:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\nas]
"file"=dword:00000001

This is how it looks in the internet settings control panel: enter image description here

I believe you wouldn't get the warning if you used the netbios name of your home server instead of the ip address. If you use the ip address or say the fully qualified dns name of the remote computer it doesn't recognize it as being in the intranet zone. the other option as mentioned earlier is to manually add it to the intranet zone list.

I have been getting the same error recently, and found a way to disable this warning forever (I know what files I want to open, so yes, I am sure I want to disable this warning...):

  • go to Internet Settings (in Internet Explorer)
  • go to the "Security" tab
  • click on "Custom level" (with "Internet" selected = first icon)
  • in the "Miscellaneous" part, select "Enable (not secure)" for the option "Launching applications and unsafe files (not secure)"
  • click "OK" and then apply the changes; you'll have a warning asking if you're sure you want to do this (you'll have to say yes)

And that's it. :) Have fun.

  • You are likely to find you get downvoted for this answer as it leads to an unnecessarily vulnerable system. – Andrew Morton Oct 3 '15 at 17:11
  • 3
    I'm upvoting, seems harsh to downvote as the OP is asking a question on how to make the system slightly more vulnerable - so any answer could fairly assume that the OP isn't looking for the most perfectly secure answer.... – leinad13 Oct 31 '16 at 16:05

Adding these two lines (without changing the default Local Intranet settings) is a quick fix:

file://10.*.*.*
10.*.*.*

You need to disconnect and reconnect shares for this to work.

The other solutions here didn't work for me on Windows 7, but I found one that worked: remove Internet Explorer through Add/Remove Programs and then Adjust Windows Features. Unclick Internet Explorer 8. No more nag dialog!

Here's how I fixed the issue. First here's my setup. I have Windows 10 on my C:\ drive partitioned with a D:\ letter drive on which I keep my personnal files. The "Windows Security-These files can be harmful to bla bla" pop-up bug came in I don't know how why or when. But it happened with only two folders on my D:\ partition drive. How why and when I still have no clues.... or maybe. But hey let's fix the matter. What I did is copy\pasted all I needed most on my D:\ drive onto an external HD. Then I formatted the D:\ drive and copy\pasted back in, bit by bit (verifying in between) the folders I had saved on my external device. Bingo problem solved. Of course this sounds curious. Technology is curious from time to time.

I think permissions, authorizations, ownerships, rights etc. may have something to do. Why I don't know but these settings came back to a default position" And I had often modified them before. Then again I can be wrong. I'm just noticing things here. Or maybe the letters on some external drives had changed because USB keys or external Disk constant ins and outs. Anyway I hope this tweak will be helpful for those who did not find a fix yet, and feel someone is watching them. I have to say this issue was one of the hardest I've ever dealt with. Jeeeez Cheeez Wizzzz dudes !

august 31 2018

  • What? Literally what? I don't think this answers the question in any way. – confetti Aug 31 at 13:57
  • @confetti you talkin to me ? Explain yourself. – Jag Robert Aug 31 at 14:39
  • The question is related to nerworking, I can't see that in your answer. Furthermore I can't see how reformatting and copying one-by-one does any good. – confetti Aug 31 at 14:41
  • @confetti all I'm saying is my tweak fixed what the other fixes did not. I tried them all. I'm not an expert but I can manage. Arguing is not an option even if you're right about the networking talk. I can be right too and I could have spared me a lot of time if I had tried my fix earlier. Am I occupying to much space here ? – Jag Robert Aug 31 at 14:52
  • @confetti: Here’s the deal: When you download (executable) files from the network, Internet Explorer flags them (your downloaded copies) with meta-data that identifies them as files that came from the network.  NTFS may be the only filesystem type that supports that meta-data, so copying the files to a non-NTFS disk causes the “dangerous” flag to be discarded.  So it works as a way of scrubbing the files you have downloaded, but you would have to do it again for every file you download in the future.   P.S. I believe that you can clear the flag in “File” → “Properties”. – Scott Sep 8 at 5:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.