1

I have created a EKS Cluster and have a domain name from freenom. I created an ingress resources with host as my domain name.

apiVersion: extensions/v1beta1
kind: Ingress
metadata:
  annotations:
    alb.ingress.kubernetes.io/scheme: internet-facing
    kubernetes.io/ingress.class: alb
  generation: 2
  labels:
    app: 2048-ingress
  name: 2048-ingress
  namespace: 2048-game
spec:
  rules:
  - host: mytestabcapp.tk
    http:
      paths:
      - backend:
          serviceName: service-2048
          servicePort: 80
        path: /*

I can access the service on myapptestabcapp.tk:32531 where 32531 is the node port! How can I make sure that the host can access it on just myapptestabcapp.tk ?

Thanks!

New contributor
srinivas kulkarni is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

https://github.com/kubernetes-incubator/external-dns/blob/master/docs/tutorials/aws.md I was able to follow this and create a external-dns enabled with ALB.

Basically make sure to do the following:

  • Create hosted zone
  • Deploy external dns
  • Deploy ingress (if you want to use ingress)
  • Create a service

I also had a free domain created with freenom.com, which I was able to hookup to my service running on EKS.

New contributor
srinivas kulkarni is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

srinivas kulkarni is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.