0

I'm installing pip on my leptop, also I just install anaconda for other uses.

When I run a script I have this error: ModuleNotFoundError: No module named 'sacred'

For that I just installed the messing module using: pip install sacred

After running the same script, I have the same error. I've understood that the script doesn't see the package. I just write another time pip installs sacred to see the following output:

Requirement already satisfied (use --upgrade to upgrade): sacred in /usr/local/lib/python3.5/dist-packages Requirement already satisfied (use --upgrade to upgrade): jsonpickle<1.0,>=0.7.2 in /usr/local/lib/python3.5/dist-packages (from sacred) Requirement already satisfied (use --upgrade to upgrade): munch<3.0,>=2.0.2 in /usr/local/lib/python3.5/dist-packages (from sacred) Requirement already satisfied (use --upgrade to upgrade): py-cpuinfo>=4.0 in /usr/local/lib/python3.5/dist-packages (from sacred) Requirement already satisfied (use --upgrade to upgrade): docopt<1.0,>=0.3 in /usr/local/lib/python3.5/dist-packages (from sacred) Requirement already satisfied (use --upgrade to upgrade): wrapt<2.0,>=1.0 in /home/mobelite/.local/lib/python3.5/site-packages (from sacred) Requirement already satisfied (use --upgrade to upgrade): colorama>=0.4 in /usr/local/lib/python3.5/dist-packages (from sacred) Requirement already satisfied (use --upgrade to upgrade): packaging>=18.0 in /usr/local/lib/python3.5/dist-packages (from sacred) Requirement already satisfied (use --upgrade to upgrade): six in /home/mobelite/.local/lib/python3.5/site-packages (from munch<3.0,>=2.0.2->sacred) Requirement already satisfied (use --upgrade to upgrade): pyparsing>=2.0.2 in /home/mobelite/.local/lib/python3.5/site-packages (from packaging>=18.0->sacred)

This output shows that the sacred module is installed on dick-packages of python3.5 I don't understand why hi is doing that.

For that I decide to search for the pip directory, by tapping pip -V, I found that used pip is the anaconda pip.

pip 19.2.3 from /home/mobelite/anaconda3/lib/python3.6/site-packages/pip (python 3.6)

I decide to create an anaconda environment using python. And after doing that when I tapped pip install sacred he just tells me that he is installed and display the same output, and when I try To search the sacred module installation by tapping pip show sacred nothing appear.

The conclusion that on installation he is using pip which is located under python3.6, and when I'd like to search for the module he points on the conda pip .

Can anyone tell me how to make the pip point on the local pip and not on the conda pip .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.