1

After much debugging, I have come to the following conclusion:

If a terminal (cmd.exe) in Windows was started with "/min" (to minimize it immediately before ever drawing it), or is currently minimized, you can't set the width/height. Even after you bring it up, it will have the default dimensions, even if you apply the command:

mode con:cols=160 lines=50

cmd.exe windows that have been opened with the default window mode ("windowed") allow me to set the dimensions as long as no output has been made when the command is run (but garbles everything if output has started).

What gives? Is there no way around this? It really is causing a lot of annoying problems for me.

Please note that I have no interest in setting the default dimensions (which I know how to do) because this needs to be fully done from my scripts.

New contributor
terminalhobbit is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • How are you starting the command prompt window? are you using start /MIN? – aschipfl Oct 10 at 9:16

Your Answer

terminalhobbit is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.