0

On my machine, I dual boot windows and linux. It was working fine as of a few weeks ago. Now it doesn't even boot. Originally, my drives were as follows:

/dev/sda5 = EFI
/dev/sda6 = swap
/dev/sda7 = root

Then somewhere along the line, my windows OS added a drive and moved everything so now it is like this

/dev/sda6 = EFI
/dev/sda7 = swap
/dev/sda8 = root

Now when I try and use my arch partition, it cannot load because it tries to boot into the original root partition, /dev/sda7 but it doesn't realize that it was moved to /dev/sda8. This is causing it to not work because it cannot recognize the swap filesystem. I can use the arch installation usb and mount the drives and interact with my files, but I want it to work on startup. Is there any way I can specify that I want to point to different drives somewhere for boot? I checked my fstab and the drives were there but they were still pointing to the right UUIDs from blkid. What can I do to fix this?

Edit: The solution was to modify my /boot/loader/entries/arch.conf file and point to the right drive.

New contributor
Semi-Noob117 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

Your root partition is not discovered from fstab1 – it is specified directly in the kernel's command line using the root= parameter. Whatever bootloader you're using for Linux, either edit its configuration file from the live USB, or make temporary changes directly at the boot menu (usually the E key allows editing an entry), to have the root= parameter point to the correct partition.

You'll probably find that the parameter directly specifies the root partition by its number (sda7). It's best to immediately replace it with an UUID-based path (just like you have in fstab).


1 Might not apply to dracut initramfs.

  • This worked! Since I'm on arch so the file was located at boot/loader/entries/arch.conf. Thank you so much! – Semi-Noob117 Oct 11 at 3:38

Your Answer

Semi-Noob117 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.