0

I'm in a real pinch. The folder contains all my files from a job I just left. I was just about to create a backup when the problem occurred. I have no intention of using these files other than for personal viewing, but I doubt I can just walk back in the office and ask for them.

BACKGROUND

• It's a WD Elements 1TB 2.5 External Hard Drive

• I use it to transfer files between my PC desktop running Windows 10 and my 2017 Macbook Air running Mojave. The folder reads empty on both devices.

• I formatted it to exFAT about a month ago. I've been using it exclusively on PCs for about 3 years beforehand. I don't remember what format it was, but I didn't modify it then.

• I first encountered the problem on my Mac.

Here's a screenshot of the problem.

As you can see, it says "Zero kb, no items." This is the only folder that's empty. Everything else is intact. I also noticed that the errant folder's "Date Modified" record is about a month off.

I'm not sure if this is relevant but if you look at the drive's info, you will see that it was supposedly created in January 1, 1970 at 8:00AM and modified on January 1, 1980 at 12:00AM. Neither of which is true.

THINGS I'VE TRIED (more or less in order)

PC

• Plugging the drive into my PC, the folder still showed up empty.

• Fiddling with the view settings to show hidden files.

• cmd: attrib -h -r -s /s /d g:*.*

Scan and repair through Properties > Tools > Error checking (There didn't seem to be problems)

• EaseUS trial barely found files, and not from the folder I want.

No luck.

MAC

• I put the drive back into my Mac. Waited a few minutes.

• Terminal: sudo fsck_exfat -d

[cmd] [shift] [.]

First Aid (There didn't seem to be problems)

• manually searching for my files in .Trashes and Recycle Bin. The errant folder wasn't there but I found files I deleted about a week ago, and files from a different folder deleted just yesterday before I discovered the problem.

[cmd] [shift] [g] to a specific subfolder in the empty errant folder. No search result.

• Spotlight searching subfolders. No results.

• Adding then removing the folder from Spotlight's Privacy settings

Let the drive sit in my Mac for a few hours, hoping the files would magically appear, like it has several times before in my experience of using external HDDs on Macs. Not this time.

• iBoySoft Data Recovery was taking forever to even get past 0% so I stopped it.

Still no luck.

I suspect that recovery software won't find it because it was never really deleted?

It's probably obvious but I just want to add that I'm not a power user in any way. I'm just a noob who needs her files back. :(

Is there anything else I can try? Thank you very much!

New contributor
Morsica is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    after what you have tried, may be this is just a silly idea..but open the folder in windows and then type * in the search box and see if anything happens, it works for me if ever my flash drive wont display the files. – Elmo Oct 10 at 4:45
  • and actually the recovery software should still be able to find it even if the files were not deleted( but for that I think you have to choose full drive recovery - hope you had made partitions on that 1TB drive !! or its going to be a pretty long scan ) – Elmo Oct 10 at 4:49
  • After a bit of scrolling, I found the folder but sadly, it's still empty. :( Thanks for the tip, though. It was worth trying! And no, I didn't partition the drive. Yikes. :D Thanks, I'll try recovering. – Morsica Oct 10 at 4:53

Your Answer

Morsica is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.