1

I have a Chromebook VPN user who has been successfully connecting to her remote workstation daily for a few months now, using the Microsoft Remote Desktop Client (for Chromebook), which is found in the Google Play repository.

Very recently, her Window 10 (1809) workstation completed some minor updates. These updates could be unrelated, but now she cannot RDP to her remote workstation.

However, I've confirmed that the VPN is definitely connecting successfully; hitting ctrl-alt-T on the Chromebook produces a terminal, and we were able to ping the remote computer over the VPN without issues.

Also, I have no issue connecting to her remote computer over the VPN using Remmina Remote Desktop via Linux (on another computer), but I do not have a Chromebook of my own for testing.

Sorry, all I have is this chopped off screenshot of the error message, when she tries to connect: enter image description here

The readable parts are:

couldn't connect to the remote PC because the PC can't be found. Please provide the fully-qualified name or the IP address of the remote PC, and then try again . . . error code: 0x104

Again, I can ping this remote workstation. There's another app, in the Google Play repository called "Microsoft Remote Desktop Client Beta". We also tried that app with careful repeated login attempts of the correct domain, user, and password. It didn't work.

I also tried removing and reinstalling these apps with the same results afterwards.

The last thing I tried, was completely disabling the Windows 10 Firewall (in all 3 places). Still, we could only ping the remote desktop, but no RDP.

Something has changed in the last couple of days that has broken my only Chromebook vpn user's ability to RDP over the VPN. None of the other remote users (who use both Window and Linux) are having any issues.

Right now, I'm upgrading her Windows 10 workstation from 1809 to 1903 in hopes that this might fix the problem, but I'd appreciate your advice too, because this upgrade may not work either.

  • 1
    Without knowing which specific updates were installed, it is difficult to detetermine, if those udpates are the reason RDP stopped working. I am aware of some security changes that happened months ago (12+) with regards to RDP. – Ramhound Oct 10 '19 at 20:44
  • At this point, I've upgraded to Windows 10 1903. The issue remains. I may have to use wireshark to figure this out. I need to test this on another Chromebook. I tried to set up a ChromeOS virtualbox virtual machine today, but I couldn't get the graphics working. I wish I could locate a working virtual machine with ChromeOS already properly installed, just for testing this issue. – LonnieBest Oct 11 '19 at 6:04
0

In order to work around this issue, we had to turned on the Linux Beta option from the Chromebook's settings menu.

Using the terminal provided by Linux (beta), we installed rdesktop using this command:

sudo apt-get install rdesktop

After this, we were able to login to the remote desktop using a command similar to this:

rdesktop x.x.x.x -a 16 -g 1920x1080 -u userNameGoesHere -d domainNameGoesHere

You'll need to replace x.x.x.x with the ip address of the remote desktop, replace 1920x1080 with a resolution that fits your Chromebook's screen, replace userNameGoesHere with the correct user-name, and replace domainNameGoesHere with the correct domain.

I don't know why Microsoft Remote Desktop Client (for Chromebook) stopped working. But it definitely did for my user on 11-08-2019. Even after restoring the Chromebook to factory defaults, I was still unable to connect to any Windows workstation over the vpn, despite the fact that I could indeed ping each workstation (and none of the workstations had port 3389 closed). Furthermore, the work-around above succeeds over the exact same VPN connection from which Microsoft RDP Client (for Chromebook) is failing.

  • I'm not sure where to report this bug, but I'm asking here. – LonnieBest Oct 14 '19 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.