0

We have an Apache web server that is used for many things. One of the functions is to run TestLink. One day my colleagues needed to upgrade PHP version from version 5 to version 7. After that some problems occured while using TestLink but most of them was solved already. But one of them still persists.

When Test execution page is opened everything works just fine until a test is selected from test suit tree. When a test is selected then there is a blank/empty space on the right side of the page, there is no specification of a test to execute (preconditions, summary, steps & results, etc.) shown as supposed to.


Additional info:

TestLink version: 1.9.14

MySQL: Ver 14.14 Distrib 5.7.27, for Linux (x86_64)

Apache webserver: Apache/2.4.29 (Ubuntu)


Looking forward for any help


UPDATE:

There is an error message in Apache error logs:

The log is: PHP fatal error: Uncaught error: Cannot use string offset as an array in /testlink/lib/execute/execSetResults.php:1368
Stack trace:
#0 /testlink/lib/execute/execSetResults.php(89): processTestCase (NULL, Object(stdClass), Object(stdClass), Object(stdClass), Array, Object(tree), Object(testcase), Object(tlAttachmentRepository))
#1 {main}
thrown in
/testlink/lib/execute/execSetResults.php on line 1368, referer htttps:/localhost/testlink/lib/execute/execNavigator.php?setting_testplan=
  • What do you have in error.log? – Toto Oct 11 at 9:03
  • @Toto TestLink log is empty, or more precisely last log is almost two years old. I've look at Apache error logs and there is a log from the time when I tried to do Test Execution. I'll update my answer with the log error message. – – Olafvolafka Oct 14 at 7:05
  • It seems like an inconsistency between php 7.0 and testlink 1.9.14 You could ask TestLink community – Toto Oct 14 at 9:36
  • You are right. I've posted this issue to the TestLink developers and they replied that this version probably isn't compatible with php7. – Olafvolafka Oct 14 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.