1

Long story short I ended up converting from MBR to GPT by manually deleting the MBR partition and creating an EFI partition. Then due to some free space issues I used gparted to shift that free space back to the system partition, ran a disk check afterward and corrected any errors. Also ran /scannow and fixed a few files.

  • The system boots fine
  • Motherboard is set to EUFI only
  • Secure boot is disabled
  • I have tried several bootrec commands with no luck
  • I am unable to get into safe mode with F8 during boot

I suspect there is a registry key or something that I am missing that will tell msconfig where the boot files actually are.

msconfig

C: and D: partitions

Interestingly if I move from AHCI to RAID I get errors regarding the BCD and windows won't boot. I'm not sure exactly what to make of that.

  • I attempted to use every method for a repair install I could find and none of them worked. So I went ahead and did a fresh install and then restored my original windows partition from an image. Then I ran bcdboot c:\windows from the PE environment and things are booting up fine now. msconfig will allow me to save settings and I can get into safe mode again. However, now I can't seem to get msconfig to stick to "normal" boot. In fact, if I select normal boot I get a startup error and have to rerun bcdboot c:\windows – Darpeh Oct 13 '19 at 14:10
  • There are no MBR/GPT partitions, but there are MBR/GPT disks. Your description of what you did is unclear. – harrymc Oct 13 '19 at 19:48
  • It is notable that I said EFI partition. I deleted the boot record partition on the MBR drive. So.. I deleted the master boot record or MBR and manually created an EFI boot parition after changing the drive to GPT. Not that it matters now. – Darpeh Oct 17 '19 at 1:11
0

No good solution here other than just doing a fresh install to get the correct boot/recovery/etc partitions. What I did was do a clean install and then used Macrium reflect to just copy my old windows partition over to replace the clean windows install. That allowed me to create the system partitions I needed to run EFI and they still point to the windows install and everything is fine. MBR to GPT conversion complete.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.