0

I'm trying to use CLEAR Motorola WiMax USB in Ubuntu as there is no support for Linux as yet. I've installed Windows XP as guest in Ubuntu and the version I'm using is 3.2.2. USB is connecting fine in Windows XP but I can't use internet in Ubuntu. Can you please tell me how to do it. Here is the configuration that could help you guys. Thanks in advance.

I'm using Two Network Adapters.

Network
Adapter 1:
PCnet-FAST III (NAT)
Adapter 2:
PCnet-FAST III (Host-only adapter, 'vboxnet0')

ipconfig [on Guest windowsXP]

Windows IP Configuration
Ethernet adapter Local Area Connection:  PCnet-FAST III (NAT)

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 10.0.2.15
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 10.0.2.2

Ethernet adapter Local Area Connection 3: PCnet-FAST III (Host-only adapter, 'vboxnet0')

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 192.168.56.101
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection 2: 

        Connection-specific DNS Suffix  . : CLEAR Motorola USB
        IP Address. . . . . . . . . . . . : 10.168.242.33
        Subnet Mask . . . . . . . . . . . : 255.255.192.0
        Default Gateway . . . . . . . . . : 10.168.192.2

IFCONFIG [on Host Ubuntu]

(Ethernet) eth0      Link encap:Ethernet  HWaddr 00:14:22:b9:9d:76  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 

eth1    (Wireless) Link encap:Ethernet  HWaddr 00:13:ce:f0:9b:0d  
          inet6 addr: fe80::213:ceff:fef0:9b0d/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:5 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:84 (84.0 B)
          Interrupt:17 Base address:0xe000 Memory:dfcff000-dfcfffff 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2292 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2292 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:171952 (171.9 KB)  TX bytes:171952 (171.9 KB)

vboxnet0  Link encap:Ethernet  HWaddr 0a:00:27:00:00:00  
          inet addr:192.168.56.1  Bcast:192.168.56.255  Mask:255.255.255.0
          inet6 addr: fe80::800:27ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:137 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:21174 (21.1 KB)
1

You should enable ICS on the Windows XP box and set the network adapter for vboxnet0 to DHCP.

The Windows XP guest has a DHCP server built-in for ICS. When your vboxnet0 adapter sends a DHCP request the guest should return the necessary configuration information (specifically default gateway) to allow Ubuntu to route traffic through it.

I don't know why you have two adapters for the guest.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy