0

Setting the scene: Server running CentOS 7 based inside a private network. On this server are both Hamachi and ZeroTier. The objective is to allow clients external to the network to connect to the server, specifically, Apache running on port 80.

The Problem: ZeroTier works fine; an external client connected to the same ZeroTier network can access the server via a web browser.

Hamachi does not work. An external client can connect to the same Hamachi network, can see the server, can ping the server and can connect to the server via SSH. However, when it tries to access a web page on the server, it hangs - doesn't timeout, just endlessly sits waiting for the server to send something. What's also quite odd is that htaccess is being honoured i.e. redirects are redirecting, but no web content is loaded.

I've experienced the same issue on two different computers, both running Hamachi - one a Mac and the other a PC.

Things tried so far...

  • Turning off firewalls on the server
  • Turning off SELinux on the server
  • Clearing DNS caches
  • Re-installing Hamachi and redhat-lsb
  • Checked Apache is listening on port 80 on any domain/IP
  • Run Hamachi on another machine on the same network - external clients can connect fine to this one.

To complicate things further, when I try to edit httpd.conf (or any Apache config file) via SSH, the terminal session stops - white screen, not responding to any key press or key combination. Something kicking in on the server to protect Apache config changes?

Any thoughts or ideas on any of this are very welcome. Thanks.

  • 1
    I would consider running tcpdump to verify if you have a network problem at all. Make sure all of your client requests and server responses are being received and sent first, then worry about potential network issues. Make sure GET requests arrive at your sever. Make sure the responses are sent by server. Make sure the responses are received by the client. If everything looks good, you probably don't have a network problem. – Andy Oct 15 at 0:06
  • Thanks, @Andy. Requests are getting through - arrives at server, server responds, web client receives response from server - it just looks like the actual content that isn't getting through. Machines on the same local network can access everything fine, as can those connected via ZeroTier; it's just those connected via Hamachi that can't. I've tried running apache on different ports and get exactly the same issue. – Rich Smith Oct 15 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.