1

I have a Lenovo laptop. This morning a BIOS update came up from the built-in Lenovo Vantage software. It installed automatically and now my laptop won't boot into Windows.

When I turn it on, it flashes a message 'System BootOrder not found' and loads grub command line. I used to have Ubuntu dual-booting on the laptop and apparently I didn't remove grub.

If I type exit at the command line the boot menu loads, where Ubuntu is still listed for some reason, and selecting the drive containing Windows just leads to the same result (message then grub).

I have tried running boot-repair from a live USB, and removing the Ubuntu record using efibootmgr, neither worked and the Ubuntu record just comes back after a restart. I also tried flashing Linux to an external HDD, but it fails with a grub efi error.

Any help would be greatly appreciated as currently I can only boot from a USB. Thanks.

EDIT: efibootmgr -v output:

BootCurrent: 0018
Timeout: 0 seconds
BootOrder: 0000,0013,0014,0015,0016,0017,0018,0019,001A,001B
Boot0000* ubuntu        HD(1,GPT,190c58e8-7a84-4530-99e6-0c4fee6dcc04,0x800,0x82000)/File(\EFI\neon\shimx64.efi)
Boot0010  Setup FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0011  Boot Menu     FvFile(86488440-41bb-42c7-93ac-450fbf7766bf)
Boot0012  Diagnostic Splash     FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0013* USB FDD:      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot0014* NVMe: SAMSUNG MZVLW256HEHP-000L2              PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-25-38-BC-71-B5-78-C1)....2.LN........
Boot0015* ATA NVMe:     VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f602)
Boot0016* ATA HDD:      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f601)
Boot0017* ATAPI CD: HL-DT-ST DVDRAM GUE0N                       PciRoot(0x0)/Pci(0x17,0x0)/Sata(0,0,0)......!N.:^G.V.T
Boot0018* USB HDD: Generic Flash Disk   PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)3.!..3.G..A.....
Boot0019* USB CD:       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot001A* PCI LAN: EFI Network (IPv4)   PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0,0x0)/MAC(54ee75ed5b92,0)/IPv4(0.0.0.00.0.0.0,0,0)x.J.+*.N.....=8.
Boot001B* PCI LAN: EFI Network (IPv6)   PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0,0x0)/MAC(54ee75ed5b92,0)/IPv6([::]:<->[::]:,0,0)x.J.+*.N.....=8.
Boot001D* Lenovo Recovery System        File(\EFI\Microsoft\Boot\lrsBootMgr.efi)

The NVMe drive (14) has Windows on it. Ubuntu (0) is not actually installed .

10
  • Have you ensured UEFI boot is enabled, CSM [Legacy Boot] is disabled, and Secure Boot is enabled (these usually must be set to the exact same options as to when the OS was installed), as that's likely the issue if this began occurring after a UEFI update. Also, the correct nomenclature matters, as BIOS and UEFI are not the same things... you mention BIOS for the firmware, but then efibootmgr, so I'm assuming you have UEFI and not BIOS.
    – JW0914
    Oct 15, 2019 at 11:03
  • @JW0914 yep, all three are set as they should be.
    – Chris
    Oct 15, 2019 at 11:03
  • I don't have the slightest then. You may want to verify the EFI boot paths are correct, which will be in one of Ubuntu's man pages (or use google). Also, please edit your question changing "BIOS" to "UEFI", as well as removing the BIOS tag, changing that to UEFI too.
    – JW0914
    Oct 15, 2019 at 11:06
  • @JW0914 The update was called a 'BIOS Update' in the software. I don't really know the difference between them, but I think I'm running uefi as it's a relatively new laptop. I've changed the tag to eufi.
    – Chris
    Oct 15, 2019 at 11:30
  • Thank you for making the change. I can't offer an explanation for that, other than Lenovo is being lazy, and while that simply misinforms their product owners, it creates larger issues when the end-user needs help for an issue related to the UEFI firmware and it's settings. How-to-Geek provides a basic explanation of the differences between UEFI and BIOS, and there's ~4 decent explanations in the 1st 10 results returned via googling "uefi vs bios" that I found helpful.
    – JW0914
    Oct 15, 2019 at 11:40

1 Answer 1

1

Solved by flashing the Windows 10 installation media to a USB stick, selecting 'Repair' in the bottom-right and running the startup repair under the troubleshooting menu.

Not the most convenient of fixes, but for anyone else having a similar problem, this will probably fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.