11

I recently upgraded to macOS Catalina and ever since my tmux seems to be broken. Whenever I run a tmux command or even just type tmux I get the error: [exited] ^[[?1;2c. I have reinstalled tmux multiple times with homebrew, I have restarted my computer, I have deleted everything from my .tmux.conf file, and I tried installing reattach-to-user-namespace just in case which seemed to be the problem for some other people but none of this has made any impact. I am using a zsh terminal and tmux used to work fine with it up until recently (no changes were made other than updating OS).

6
  • What is the default shell listed in your .tmux.conf file?
    – DrZoo
    Oct 15, 2019 at 19:53
  • @DrZoo I set it to zsh
    – mlz7
    Oct 15, 2019 at 20:42
  • and yes I sourced the config after every change
    – mlz7
    Oct 15, 2019 at 20:43
  • I'm also facing this problem. Did you find a solution?
    – Leo-T
    Oct 20, 2019 at 4:19
  • 1
    @Leo-T I was able to resolve it by uninstalling, restarting, installing, etc. a couple of times -- not sure what exactly the problem was but I think it has something to do with not cleaning up the prior installations
    – mlz7
    Oct 24, 2019 at 20:41

3 Answers 3

14

I encountered same problem for byobu.
I tried

pkill byobu..

not resolved...
Then I tried

pkill tmux 

and it solved the problem for me...
The problem might've been due to tmux upgrade which was earlier this morning...
tmux 3.1a -> 3.1b

Also check this link to another related answer.

0

Ok so since posting this question, my problem seems to have resolved itself. I have not changed anything with regards to my tmux installation directly so I am not 100% sure what exactly caused this issue or how it was resolved (apart from maybe restarting a couple more times?). I am posting this for future reference but if anyone is able to figure out why this problem was happening, I will gladly accept their answer instead.

0
0

Kill the old tmux processes, and then reinstall again.

ps -ef |grep tmux
1
  • 1
    rifaqat already suggested pkill tmux, and the OP reported that the problem went away after reinstallation, so you don’t seem to be suggesting anything new here.
    – Scott
    Aug 24, 2020 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.