23

I was playing around with some SSL settings in Emby, and I managed to get this 'Secure Connection Failed' error which says:

An error occurred during a connection to emby.home.local:8920. PR_END_OF_FILE_ERROR

Secure Connection Failed Error Message

What is this error message trying to tell me? Is there any Firefox documentation where this error message is listed?

  • Is this still an issue for you? – Graham Perrin Jul 23 at 17:10
  • @GrahamPerrin I don't remember what I did to create the issue, but I still want to know more information about this error (preferably firefox documentation). – aman207 Jul 24 at 12:55
11

This error means that Firefox wasn't able to establish a secure connection and that all cipher suites failed (Firefox reached the end of the list).

Here are some thoughts about the cause:

  • The post says that you "was playing around with some SSL settings", so it is possible that you have specified some cipher variants that are not supported by Firefox or by the website you are trying to reach. Try to reset your settings to their initial state.

  • This can happen if you use a proxy or VPN or have other software that intercepts the connection and acts like a man-in-the-middle. Check your settings, and if using a proxy or VPN, try instead to connect directly.

  • It can also be the antivirus software. Try to disable or uninstall it.

  • Profile corruption is also a possibility. Go into about:profiles and use "Create a New Prof‌ile" and set it to default. If this is working, export your bookmarks from the old profile and import them to the new one and continue using it instead.

| improve this answer | |
  • For me it is the opposite. Direct connection sometimes fails, and it shows this message. A connection through my VPN works. My ISP is Claro Colombia. – Nicolay77 May 13 at 5:39
2

I had this same problem using AWS LightSail. It ended up that port 443 was blocked by the server and I had to open the port up through the console.

| improve this answer | |
0

I had this problem when I had a typo in the country name (UA instead of US) on an IIS Server, and FireFox returned the indicated error (egg on face).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.