45

I was playing around with some SSL settings in Emby, and I managed to get this 'Secure Connection Failed' error which says:

An error occurred during a connection to emby.home.local:8920. PR_END_OF_FILE_ERROR

Secure Connection Failed Error Message

What is this error message trying to tell me? Is there any Firefox documentation where this error message is listed?

3
  • Is this still an issue for you? Jul 23, 2020 at 17:10
  • @GrahamPerrin I don't remember what I did to create the issue, but I still want to know more information about this error (preferably firefox documentation).
    – aman207
    Jul 24, 2020 at 12:55
  • To me, it happened when trying to access a Docker image with an ASP.NET Core app and I have not enabled the use of development certificates.
    – Palec
    Sep 11, 2020 at 16:47

7 Answers 7

23

This error means that Firefox wasn't able to establish a secure connection and that all cipher suites failed (Firefox reached the end of the list).

Here are some thoughts about the cause:

  • The post says that you "was playing around with some SSL settings", so it is possible that you have specified some cipher variants that are not supported by Firefox or by the website you are trying to reach. Try to reset your settings to their initial state.

  • This can happen if you use a proxy or VPN or have other software that intercepts the connection and acts like a man-in-the-middle. Check your settings, and if using a proxy or VPN, try instead to connect directly.

  • It can also be the antivirus software. Try to disable or uninstall it.

  • Profile corruption is also a possibility. Go into about:profiles and use "Create a New Prof‌ile" and set it to default. If this is working, export your bookmarks from the old profile and import them to the new one and continue using it instead.

2
  • For me it is the opposite. Direct connection sometimes fails, and it shows this message. A connection through my VPN works. My ISP is Claro Colombia.
    – Nicolay77
    May 13, 2020 at 5:39
  • @Nicolay77: Better ask this in a new post with all the pertinent information.
    – harrymc
    18 hours ago
4

I had this same problem using AWS LightSail. It ended up that port 443 was blocked by the server and I had to open the port up through the console.

3

I had this problem when I had a typo in the country name (UA instead of US) on an IIS Server, and FireFox returned the indicated error (egg on face).

2

The error is often not related to the browser. In our case it was also not a configuration thing of nginx, but a wrong setting of the firewall. So logically, when I say that often has nothing to do with the browser, server-side and not client-side. Accordingly, it was not a proxy or VPN.

1
  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places.
    – DavidPostill
    Mar 15, 2021 at 10:40
1

I have a paid VPN service and I use several add-ons. All are designed to prevent tracing back to my actual IP Address, remove tracking cookies, prevent auto-install trojans or viruses and prevent any other known hacking methods. I find that when the site I want to visit cannot trace back to see my actual IP address, it gives an error code "Proxy end of file error" because it was bounced to more than one IP address. I will then disconnect the VPN, keep all the other add-ons active, and make sure to connect directly to the site I want. When I'm done, I logout, close the browser, turn the VPN on again and re-launch my browser.

1

I noticed that simply switching to another VPN server or opening the URL in chrome (webkit) can fix the error.

0

Had this issue when using Surfshark VPN while working with virtual machines in VMware Fusion.

I could not access the AWS console or login into GitHub

Tried a lot of things to fix it such as:

  • Reinstalling my VMWare
  • Setting a new VMWare virtual machine

but none worked.

Here's what worked

I noticed that this error started after I updated the Surfshark VPN

Changing the connection protocols resolved the issue.

  • Open the Surfshark application
  • Click on Settings
  • Then Advanced
  • And lastly, Protocol. Here, you will find all of the available protocols, including IKEv2, OpenVPN UDP/TCP, WireGuard, and even Shadowsocks.

enter image description here

So for me, I changed it from WireGuard to IKEv2, and that solved it.

Resource: Why am I unable to access some websites while connected to Surfshark?

That's all

1
  • I also faced the same with Surfshark but their IKEv2 slow af. I ended up switching to native WireGuard client after getting the config file. That fixed it.
    – Neeraj
    Nov 15, 2021 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.