1

I am using a swap partition of 10.5GB (almost) while RAM of my system is 8GB. My

/etc/fstab

file looks like this

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda4 during installation
UUID=19ea5c3c-94ff-4678-a071-f2990aac9191 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=C6C7-F14C  /boot/efi       vfat    umask=0077      0       1
UUID=9dab264a-b79a-42bc-affb-5b541ffaa057         none       swap     defaults    0   0
# /swapfile                                 none            swap    sw              0       0
/dev/disk/by-uuid/4C3886483886314E /mnt/Data auto nosuid,nodev,nofail,x-gvfs-show 0 0

swap is automatically mounted on boot (works fine) when I execute the command

sudo pm-hibernate

It waits for sometime then pc shuts down (which is good). The problem starts when I boot it after the whole process. It does not continue where I left. It just boots like it does without above process.

I also created a file

/etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

and added this in the file

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

But it does not seem to do anything. Can anyone tell me how to hibernate ubuntu 18.04.3? I want it to automatically hibernate on critically low battery level and also after 1 hour long hybrid-sleep/suspend/sleep. My laptop is Dell Vostro 14-3468. Plz, help guys...

1
  • 1
    If you are using Secure Boot, then hibernation is disabled as a security risk. I have this problem, and I don't want to disable Secure Boot, but I don't think there is another solution. (Note, I haven't verified that hibernation works with Secure Boot disabled.) – AFH Oct 17 '19 at 12:37
0

Problem is partially solved. I just needed to add

resume=UUID={UUID of swap partition)

in kernel parameters in general section of grub-customizer. I also installed a gnome extension 'Hibernate status button' for easy hibernation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.