0

Sorry if similar questions have been asked, but this is beyond frustrating. I have a job where I'm allowed to stream audio. In my case, I have playlists on YouTube that I listen to while I work. Why I'm working from the office, I listen on my headphones, which are directly plugged in. Sometimes, I have issue with YouTube recognizing that the headphones are plugged in, and the audio plays from my laptop speaker. The simple solution to this is to close the browser and re-open it.

However, on the days I work from home (which is more often than not), I'd like to listen on a bluetooth speaker I have paired with my PC. When I pair it, I see the same issue that I see with the headphones. YouTube plays from the laptop, rather than the Bluetooth speaker. I close and re-open the browser, fire up a playlist and it works... for only the first video.

Every single time, once the first video is over, or I switch to a new one, YouTube switches back to the PC audio. To make matters weirder, all other PC sounds (like desktop notifications) always play from the Bluetooth speaker, as it should.

Other odd observations, if I open the Windows 10 volume mixer, I see that "System Sounds" and "Chrome" are assigned to the Bluetooth device. However, there are no audio-level changes coming from the Chrome mixer. However, if I switch the visible profile to System Speakers/Headphones, I see that there is a second Chrome mixer, and this is the one that's showing audio data.

What's going on and how can I fix this?

0

Well, I've yet to figure out why this happens to YouTube/Chrome, but I've resolved the issue. If you want to specific an output device for Chrome, follow these steps in Windows 10.

  1. Right-click on the volume icon in your task bar, and select Open Sound Settings.
  2. Scroll to the bottom of the screen and click on the Advanced sound options -> App volume and device preferences option.
  3. On this screen you will see a list of "Apps". If Chrome (or any application) is behaving badly, then the chances are that a specific device is selected for output.

Since I want my system to behave consistently, I toggled from "Speakers/Headphones" to "Default". Using the default option should always output to wherever all system sounds are being played. If output is acting odd, then you can change the current settings (which are used for the app defaults) from the Master volume, Output and Input selection options at the top of the App volume and device preferences screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.